2.66 ambient occlusion

Hi all !!!

Big advance in the new release: ambiant occlusion baked to vertex !
I’m among the numerous ones awaiting for this and was really happy this came with this new release.

Unfortunately, it don’t work.
I found no info about how to use it, and assume it’s just like older versions that baked to texture.
But blender uses to tell me there’s “no objects or images to bake to”. OK the i select an object, an image,
and a pizza from my fridge, but it’s no solution on this.

too bad !

mebe there’s a lil doc somewhere ? Or mebe it’s just been coded with the feet ? ( i got a dubt on this last case :stuck_out_tongue: )

If anyone made this work, please leave a lil how to over here :slight_smile:


In the Render / Bake panel select ambient occlusion, enable the ‘Bake to Vertex Color’ tickbox. Then press Bake. Tried in 2.66 testbuild1 and works

Moved thread from Latest News to Support forum.
Please post in the correct place in the future!

sorry i was not quite sure of the place to post to.

In the Render / Bake panel i selected ambient occlusion, then the ‘Bake to Vertex Color’ tickbox. Then pressed Bake. Tried in 2.66 testbuild1 and just don’t works.

I just saw on the wiki that ambocc baking seems messed up for those using windows.
Il also tried in my now usual 2.64, and i can’t make it work for baking to texture. I think i’ll have to search this forum for

Did you look at the objects vertex colour after you pressed bake by changing to Vertex Paint mode ?

lol of course i do

:wink: i spend 10s hours vertex painting my models. I believe you know that when an error message appears in blender, it’s that the work is not done ? An this is what’s happening to me.
Nevertheless it appears that baking anything is impossible. I guess am missing something like an obfuscated setup or some black voodoo for making it work :wink:

I’ll be back there when am able to bake something with blender.

OK i tried out AObaking on the startup cube…

  1. unwrap the cube
  2. create a texture eg 1024x1024
  3. press bake after choosing ambient occlusion

all works fine.

Now i load my already unwrapped & textured model

  1. unwrap it
  2. create a texture
  3. press bake blah blah blah and i get this:

I have to say i’m under windows… and it seems it just dont work in windows as blender wiki says :frowning:

too bad…

Of course, i also tried to del all materials and UVs and recreate one, but with no success.

In order for Vertex Baking to work, you need to create a Vertex Color Layer first.

For the other case, make sure you have the UV faces assigned to the image. Select all faces, then select your image in the UV editor from the dropdown, even if it is already selected. This works in a bit confusing way. Just play around with it.

Demo showing baking AO http://screencast.com/t/FX44l2cc8Z

Thanks Richard for the video. :smiley:
I already watched some on the web, and did all that is specified in them. And NOTHING WORKS !!!
I confess this is my fault. I found a thread on this forum talking about the ‘renderability’ of an object. My object
was not renderabled. I think i did a bad keypress, as i never use the outliner. and now that object is renderable again,
everything works fine :slight_smile:
Nevertheless, AO baking is still not what i want as i need to bake a room ( with normals inside ) AO. and the given result
of AOBaking is for objects seen from outside.

Anyway thanks for you help :slight_smile:


EDIT: why i finally had this problem ?
Some blender users who use blender as a renderer would have quickly found the source of the problem.
The point is that i NEVER use blender’s rendering ( neither cycles nor internal ) as i only model for games. Therefore, the renderability flag had no importance to me… till i use AObaking :wink: