2.66 crash on dynatopo?

So when I toggle into dynamic topology mode Blender crashes. I tried updating my graphics card driver, but it is unable to connect with the mother ship for some reason. I suspect it’s just an issue with my old computer, but I thought I would see if anyone else was experiencing this behavior, before deciding whether or not to file a bug report.

I can’t reproduce this on r54622, have you tried on a recent buildbot version (as the 2.66 release candidate is a bit behind the buildbot now) to see if you are running into a bug that has been recently fixed, as i noticed a few dyntopo crash report (though not similar to yours) ?

And is it crashing on a specific model , or is it crashing even if you’re enabling Dyntopo on the default cube ?

edit : i noticed this report that sounds very similar

Check if by any chances the devs replies may help

yeah, it was the default cube the first time, and the second time. I subsurfed it, applied the modifier, then tried it again, and same thing. tried both the hotkey command and the button, both crashing. It was the build from the main site. I guess I should try one from graphical. And yeah, I looked through the bugs, but I don’t see anything like this. So, I guess I should try a newer build, and see what happens.

I get this too, on the release.

i got 54641 on windows 32 bits and it does not crash!

also just got 2.66 and not crashing


64, windows 8 on an asus g73sw, Crashes with no error message.

i also have an asus graphics card. looks like I am too late to make a bug report though, as 2.66 has just been released.

I don’t think it would be too late to report in details, it’s possible at some point soon they release a version 2.66a , they have done this for previous versions.

true, I should probably include a link to this thread just to emphasize that it seems to be a common issue with asus cards.

I also have Windows 8 64 bits and blender also crashes when I enable dynamic topology, so I think it is an extended bug…

I tried it in a Windows 7 64 bits and it works fine.

Update to the latest drivers from nvidia instead of those from asus, and now it works fine.

Someone made a report on the bug tracker about Dyntopo crashing for them:

So if you experience a crash too, i highly recommend that you add a comment in that entry with your hardware specs/eventual error message/how to reproduce your own crash.
The more people add their crash experience , the better the chance the devs may see what’s the problem.

I have been trying to update my nvidia and asus drivers, but I think the problem is, they are so out of date, that they don’t offer updates for them anymore. Looks like I might need a new graphics card. But yeah, bug report seems appropriate, as this is obviously widespread.

I’ve also had problems with Dynatopo crashing. As soon as I press “Enable Dynamic” and the confirm, Blender closes instantly. 2.66 Site release, no GPU, Windows 8 64 bit

There are a few crashes that have been fixed with Dyntopo, the last crash fixed has been in revision 54971

So download a version of Blender 2.66 superior to r54971 on the buildbot to see if the crashing bug you experienced on the “stable” release version of blender (that is only revision 54697) with Dyntopo is now gone (and so will be too when Blender 2.66a will be released).
builbot has new updated build nearly everyday, so if you don’t see yet a build superior to r54971 for your OS, wait until tomorrow, there’s certainly going to be one.

In case you still crash on a buildbot version of Blender with Dyntopo, report it on the bug tracker (the few crashes fixed up to now have been the ones reported there) :

Because if you don’t report your specific crash with information on your system and how it crashes exactly, there’s nearly no chance your crash will be fixed.