2.66 fluid physics don't work -- for me

I tried several pre 2.66 tuts about this topic but the process seems have changed a bit lately. Therefore I’m a bit stuck in my attempt to train the physics stuff: I simply cannot figure out what more to try.

What I want:
the very basic fluid animation: a falling body of fluid into a container.
What I’m stuck with:
the same cube dropping and bouncing into the container when pressing alt-A. But the fluid deformation? No show!

What I do:

(1) Arrange objects. Subdivision (W-key) of the “active one”.
(2) Make fluid “Add active” in the tool-panel (T). Properties, Fluid type “Fluid”, Rigid Body type: “Active”.
(3) Make domain “Add passive” in T-panel. Properties, Fluid type “Domain”, Rigid Body type: “Passive”.

I’m obviously missing something … obvious …
Please help me some one.

Kind regards, Mikael

Sample file
http://raaskot.dk/raalab/blender/physics_fluid_02.blend

Some screen dumps:


I think you are mixing physics systems here. You can have animated obstacles but you might want to bake that physics simulation before you run the fluid simulation.

Hi Atom.

Hmm, I’ve tried to Bake (to Keyframes, T-panel) the Active (fluid) part, but no changes occurs. First I baked the falling box producing keyframes, then I tried to choose fluid again, then do another baking. The passive domain box cannot be baked I guess. Sorry to expose my noobiety (I’m lost;) what systems may I have obscured? Can you see what I mess up?

Kind regards,
Mikael

I did take a look at your file. I am just not sure what you are trying to achieve. You could make the cube an inflow, is that what you are looking for? Or do you want the cube to be a control object to hold the shape of the fluid? The fluid, of course, will be contained by the walls of the domain but domains can not change size or location during a fluid sim. (I think animated domain size is on the todo list, however)

I understand. I appreciate indeed any help you can provide. I’m trying to get what this guy does from time frame 1:20 till approx. 2:00 in this video:

What do you think?

The version on display is obviously prior to 2.66.

Kind regards,
Mikael

  1. Reason is not baking is you have 2 domains, Cube and Cube 002. Delete one. You can only have 1 domain for a scene. Bakes fine for me after deleting one of your domains.


  1. You also have a torus assigned as a fluid object. Not sure if you wanted that as well.

  2. If all you are trying to do is make the box turn into fluid and drop to the bottom, like in the video, you don’t need to animate your cube. Just position it and set it to fluid. Then bake. The fluid sim uses scene gravity so it will take care of that part for you.

You don’t need the additional physics for that.

However, animating a fluid object or inflow can cause issues with the fluid simulator. Sometimes not having a high enough water domain resolution for a high poly/too small an object will also prevent your object from turning into fluid. So keep that in mind.

But you can’t animate a fluid object and have it remain a fluid in the shape of your object. You need to do that with either an inflow or a control object. A fluid object turns into a fluid on frame 0, then that’s the last bit of control you will have over it. After that it becomes part of your fluid sim and your animation(as a fluid) is ignored.

It works now!

Many thanks to you both for kind involvement and thorough explanations. I wouldn’t have figured it out my self. Indeed I messed up several things: I’d activated the T-panel “Rigid body” settings, which conflicted with the values put along in the Physics properties. Also the excessive “domain”-objects in another layer messed it up. The torus thing was rudiments from several hapless tests.

Keeping my fingers off “Rigid body” settings made it work like in the videos and other instructions I’ve seen.

I still need some work to get the grasp on all of the parameters but your great help made me fathom what on earth I was doing. Thanks, gratefully, Alexglass and Atom!

Kind regards,
Mikael