2.71 Background shows in Render view not with f12 to render out?

Hi All,
I have a PNG I am using as a background image. I used add as background image in menu. I did NOT use UV unwrap or any Node to do so. I DID enable use BG image (png) and have tried to F12 using Transparent checked and unchecked and getting no image for a BG. ??
What am I not doing?

F12 Out BG does not show?

With “T” unchecked

Is my problem in here ?

You are using the background settings in the viewport N Panel that are mean to be used as reference - from this point, you need to load your image as texture in your world material and map it to the same coordinate.

Thank you Craig. Ref Only. I did it this way… Should I add it as a texture to my world the same way I do an object? I have yet to do that.

That is a fully acceptable method for final render, but you might want to blur it some for DOF. You can also add it in the world material there and add a mapping node to set it correctly, those nodes are available there in your bottom node window.

Ok right Blur the BG for depth
Adding it (the BG) as a world material ( I did not see how to do that) (Maybe you got a screen grab and some instruct on that?)

Then those Nodes are just like any other ‘Objects’ Nodes where I can Map, Emitt, etc. By just using SHIFT +A to select them?

Sorry to read if it is obvious but I am trying to get clarity
Thanks for your help

Here is a set up that sort of works - mapping to window puts the image in the same range as the background settings I had mostly.


Ok Craig thanks.
Why Window for your Coordinate? (Something better then UV?)
Where is Background Node Found? V2.71

The To add nodes to world, One must select World Node editor… as in pic. Got it!

OK found BG under shader. Tried using UV but no good. Switched to window as yours is. But put some of the stars in front of my model. Even tried a diff pic, which was even more predom. Do you know why the BG would do that? I have the other node tree disconnected as in my pic above showed as an acceptable way to do it according to you.

UV is for UVW coordinates, as in the flat coordinates for 3d mesh when unwrapping. Without a mesh, I do not think UV comes into play for the background unless you are projecting to a mesh object you have unwrapped in edit mode.

How do you guys know this stuff? Any idea why my stars went in front of my model?

Dude, reading all the forum threads I can for years now…lol

I don’t know why that is with the stars in front, unless you have got the image loaded on top of your scene with a mix mode

No As you see it above. Maybe it is one of those Blender open/close mysteries? thanks