2.71 "halting" on OS X Mavericks 10.9.4

I am getting back to Blender after some time away, and working with very simple shapes trying to do simple modifications which are not CPU-intensive…things like loop cuts and bevels…

It seems like everytime I try to use a tool, Blender freezes for a few moments. then it returns to User control. Is there something about 2.71 and Mavericks that causes this? Anyone else?

I’m using an 8-core Xeon with 16GB of RAM, so plenty of resources to run Blender, which I’ve never had this trouble before.

Thanks for any ideas!

I use Blender on a Mavericks Mac with significantly lower specs than yours without this trouble. You say this happens “everytime” but can you be more specific, perhaps supply an example file and what operation exactly causes this lag? Maybe a clearer idea of how long exactly this lag lasts? Et cetera?

Sure…I created a cylinder mesh object in preparation for turning it into a gear I’m envisioning…I could make the loop cuts ok but I got a lot of this halting almost as though Blender was trying to remember what to do!

I just opened a new document and tried to repeat my steps and didn’t get any of the halting I got earlier…no clue what explains the difference; I have the same stuff running now as then, IOW, nothing demanding…computer basically twiddling its thumbs…

Is it possible that, the first time 2.7x is asked for a tool, etc, that it must un-compress or load things? Could something like that account for first-time lagginess? I’m just theorizing here… Mavericks was like that…first time it drew my applications window, it did each icon one by one. Next time, all icons present in no time.



Moved from “General Forums > Blender and CG Discussions” to “Support > Technical Support”

Yeah, I think this is a Mavericks issue in general, not specific to Blender. I don’t think it’s a “first time you run a thing” thing either. I had something similar this morning in iTunes for no discernible reason, then it went away. It hasn’t happened often but I can remember one or two other incidents of unexplained transient lag in random programs.

I’m on 10.9.4 and never faced this issue, a certain lag can appear some times if I have two or more renderings running in background but this is acceptable.
As for Blender, it could depend on some setting, try for instance to change the ‘Window Draw Method’ in User Preferences->System, and see what happens.


thank you…I’ll take a look at those settings. at the moment, the settings are whatever 2.71 ships with.

Try to keep the Activity monitor open. When this happens, have a look to see if it’s Blender or rather some OS background task that is causing this. Many people were reporting that after upgrading to Mavericks that the Spotlight indexing was taking up a huge amount of CPU time. After doing some digging, I found that this was being blamed on a settings conflicts that were left over from the previous OS version.

I confirm the Spotlight issue, in fact I had to totally disable it, since it was slowing down the comp every few moments, whatever application was active, so, from this it should be quite easy to distinguish from a blender issue.

BTW, if you have some hint about the resolutions of this conflict, or a link, please share it.


I avoided this problem by doing a clean install. I used the following article to prepare a removable drive for booting a Mavericks installation.

and another related one.

If you don’t want to go through all this then you can try disabling indexing which is what I did after installing Mavericks just to be sure.

The following command is for disabling Indexing but it should leave Spotlight active so you can still search sudo mdutil -a -i off

I always disable indexing even with Windows after I diagnosed a friends machine and saw that Windows7 indexing was using 30-50% of her CPU usage which was all devoted to keeping her HD constantly busy. Indexing seems to be far more trouble than it’s worth.

If you disable indexing, you can still search your HD but it takes longer because the results are not pre-cached from the index searching.

There is another problem with Mavericks which can cause similar issues and the following article also shows how to deal with this. This one is related to the System Stats utility. http://osxdaily.com/2014/02/27/systemstats-cpu-use-slow-mac-os-x/

BTW, the people at osxdaily.com are really on top of things and they write straight-forward articles that are easy to understand so you may want to browse through the site and see what else there is which may be of use to you.

best wishes, Marc.

Thank you very much Marc for detailed answer and several useful informations, very kind of you.

I never had problems with indexing before Mavericks, if it works good it take CPU only first time, no problems.
I didn’t know it was possible to perform searches with indexing, good to know, I disabled spotlight and removed all data from disks, anyway it should comport to have at least a complete indexing, but at the actual state my maverick seems not able to do.

I’m going to look at osxdaily site.