[2.71] Sculpting slow/hangs and 100% cpu

(Nemozini) #1

Hello

Anyone else having the same problem?

Test:
I subdivided the default cube two times then added a multires modifier (x4 subdivide) which is about 25k vertices.

2.71 sculpting just hangs and CPU jumps to 100% on all threads.

Downloaded 2.70a and did the test again. Sculpting works fine!

i7 2630m / Win 7 x64

0 Likes

(VladArtist) #2

for me it’s the same thing = (

0 Likes

(antmanlfe) #3

I have the exact same thing and have desperately searching for ages for a fix. I mean you would even get some lag on the default cube…

I just tried your suggestion and am using 2.70a and it is as smooth as silk. Definitely looks like a bug in the new version.

0 Likes

(mib2berlin) #4

Hi, I have no problem even with 5 or 6 multires + 2 subdivide with 2.71 on my crappy Dual-Core CPU T4200 @ 2.00GHz 4 GB ram laptop with Intel i965 integrated grafiks chip.
I am on linux opensuse 13.1 64 Bit.
A cube is a bad example because Blender is optimized for complex mesh, may try suzanne.

Cheers, mib

0 Likes

(antmanlfe) #5

In contrast i have quite a powerful computer. i7-930 Hyperthreaded and overclocked with 24gb’s of ram.

For my test scenario i start with a cube and apply a subdivision of 14. This produces a sphere of a bit over 6.2 million faces. If i then go into sculpting mode i see the following.

I have tested my version and the latest build of of blender both 2.71 and have noticed that cpu usage goes to 100% during sculpting and as such there is lag. (Even when using simple meshes like suzanne)

In contrast if i run version 2.70a with the same subdivided cube my cpu usage never goes above 20% and as such there is no lag

–I have just tried the legacy build of blender 2.71 vc9 and i am getting the same performance as 2.70a!! So i guess my solution is to use that version about and hope they never discontinue it… (Unlikely i know)

Note i am only using 64-bit builds

0 Likes

(Sanctuary) #6

Same problem on my windows (32bits) , on “official” buildbot versions of 2.71 , any sculpt strokes jump the CPU usage to 100% directly, while just having tested the “legacy vs2008” , the CPU usage is less than half of this.
the bug has been reported :
https://developer.blender.org/T41193

Thanks for the information, i’ll drop my current version and will stick with the “legacy vs2008” from now until it’s fixed.

0 Likes

(Sanctuary) #7

Sergey fixed it here : rB115458b53e5e

So if you use sculpt a lot and are using Blender 2.71 or 2.71 buildbot on window, make sure to get a new build (probably tomorrow) once they will be available with this bugfix part of it

0 Likes

(Nemozini) #8

Glad this is getting fixed. Staying on 2.70 for now.

0 Likes

(Sanctuary) #9

Actually it’s unfortunately not fixed, it looks like the problem was deeper and was basically OpenMP that is not working good with the mscv2013 compiller (while there was no problem with the previous compiller, and why 2.70 or the “legacy vs2008 2.71” on buildbot aren’t affected by the problem). The devs put that on “todo” as the fix will require a lot of work, no idea if it will be fixed before 2.72 then.

The only way to workaround the high CPU usage in sculpt in 2.71 and “official” buildbot (legacy vs2008 isn’t affected as already said) is , while in Sculpt Mode, to go to Options and -disable- Threaded Sculpt (disabling then OpenMP from sculpt), this way the CPU usage drop a lot to normal.

0 Likes