2.72 mouse look problem

I tried new mouse look in 2.72, but I have some problem.

When I tried to look around, Y-axis works just fine it respond to slight mouse movement. But there seems to be slight threshold for x-axis (set at 0). I need to move my mouse at certain distance before x-axis respond. Start the stand alone player give the problem. Anybody have an idea. Thank you.
MouseLookProblem.blend (449 KB)

I dl’d your blend and there’s no script or attached, an the actuator on the camera is blank. :confused: maybe it’s because im using 2.69, but afaik you at least need a simple script to be getting a mouselook going.

Seems to be a bug in the blenderplayer. Please report it in the Blnder bug tracker.

I see, thanks.

Bah, I made my own thread and then noticed this. I have the same issue. But to me this happens inside Blender.

@ka0s420in Blender 2.72

Hey, thanks for the file…couldn’t get it to work at all at first. I TURNED the sensitivity DOWN and that seemed to cure the problem!

Be sure to try downloading an earlier version of the script, I had lots of problems with 2.72 so I just went to an earlier one.

Yeah I’ve noticed if you move your mouse very slowly the unit won’t even move.

Mouselook is a new, built-in feature in 2.72. No script needed.

hmm, okay well thanks for the info. Guess i should update soon.

Hi Kevin,

This is due to you use an odd horizontal screen resolution (i.e 1025x768). If you use an even resolution (i.e 1024x768) then you will obtain a smooth movent even with slight mouse movement.
Anyway, I will check it to see if there is any issue related to stand alone player.

thanks for report it.

Hi again,

i have been investigating and this problem exists when:

  • when you use a odd resolution. This issue is known but it doesn’t imply so much problem because everybody use a even resolution.
  • when you use the blenderplayer in window mode + a resolution close to or bigger than your desktop resolution.

In your case if you use a desktop resolution of 1920x1080, a workaroud should be to use a resolution of 1910 or 1900 x 1080 or to use a fullscreen resolution of 1920x1080

I will try to make a fix a.s.a.p.

Hello everyone!
And no, no, no. It’s a BIG problem in 3D viewport. It’s even worse because there is no any information about your current resolution (in 3D viewport). I have to resize Blender window itself untill it fits in EVEN RESOLUTION (i feel just like a blind cat). And when I resize other internal Blender windows 3D viewport follows changes its size and it makes a problem EVEN MORE ANNOYING! I use 3D viewport to make some “quick” benchmarks/tests right in place (“quick” because BlenderPlayer takes some time to load (around 5 sec for me) where 3D viewport is as fast as hell).
My english is not very good so there maybe a lot of mistakes. sorry :slight_smile:

Still a big problem even at even resolutions, any fix yet?

In the ancient version of Blender (2.49b) your Animation Frame Rate, on the camera settings, had to be set at the same frame rate as the BGE. The Default in your file is 24 fps; the GE is set at 60 fps; I think u should start by resetting the Animation Frame Rate to 60.