2.72 Smoke Rendering issue?

I’d find it hard to believe that there isn’t a simple explanation, but for some reason, I can’t get smoke to render in 2.72. I’ll do it as basically as setting up Quick Smoke, which already has a material, then render–nothing. I break it down to the volume scattering and attribute nodes–nothing. Everything seems to get lost once I plug that attribute node with “density” as the name into the volume scatter node. I re-downloaded 2.71, set up Quick Smoke, Volume Scatter and Attribute nodes–it works just fine. I’m thoroughly confused, so if someone could help out, I’d appreciate it.


It would be great if you could supply a .blend file to see if the problem is in another person’s copy of blender or not. Thanks!

Sorry about that; here’s a file, and the version is just the stock 2.72 from the blender.org site.
Smoke Problem.blend (527 KB)

I opened up your blend file and it seemed that everything worked fine. The scattering attribute worked fine and all the smoke volumes were there. The flame attribute didn’t work, but that was because your input object was set to ‘smoke’ only instead of ‘smoke + fire’. I dunno why it wouldn’t work in your version of blender. Probably a bug or a missing program file. I may try getting another copy on blender.org. Maybe try re-typing the attribute name in each of the attribute nodes or just making your own smoke system.