2.73 - Branched path tracer crashes with particles and volumetrics


I tried rendering an scene today with the branched path tracer and found that Blender always crashes after a minute or so of rendering (several tiles have been rendered at this point). The exact message is the rather mysterious “Blender has stopped working”:

Some info:

  • The scene has 4 layers (objects, lighting, particles and volumetrics). The scene renders fine if I only render layers 1, 2, 3…or 1, 2, 4…but it always crashes at some point if I try to render 1, 2, 3 AND 4.
  • I’m using the latest version of Blender 2.73 64-bit, downloaded today.
  • My computer has 32 GB RAM and I’m CPU rendering on a stock i7-4770k.
  • According to task manager I have at least 9 GB of RAM spare at all points during the render, including at the point of the crash. Blender was reporting a steady memory usage of 6837 MB.
  • If I change the number of samples, then more of the image is rendered before the crash occurs, if I increase the samples then less of the image is rendered.
  • I am using the standard feature set.
  • The scene renders fine with the standard path tracer, but it is incredibly slow in comparison. I don’t know why exactly this the case for my scene, but a quick test I did now to demonstrate this showed that I had comparable noise in a 3 minute path traced render vs 15 seconds in the branched path traced render. Given that my final render is going to take many many hours with the branched path tracer, I know now that the normal path traced render would take a prohibitively long duration.

Branched path settings:

  • 1 sample for every type (diffuse, glossy etc)
  • 0 clamping
  • Tested with 1 to 100 AA samples (square option not checked)
  • Sampling all direct lights
  • Sampling all indirect lights
  • Sobol pattern (tested correlated multi-jitter too)

I actually had this problem with all the earlier versions of Blender too, but I’d never paid it much attention since I wasn’t near the rendering stage with a project that was affected by the problem.

Any ideas why I can’t render my volumetrics and particles layer in the same pass when using the branched path tracer?



For me Branched path tracing doesn’t work at all - it never has. However, I just had a breakthrough (admittedly it’s not going to help me much), that it worked when my tile size was 64, BVH was dynamic and nothing everything else was unchecked. Usually I have it at 512 or somesuch.

I have not found any relevant material on how to make it work, if the solution is “very simple.”

On blender 2.73.