2.74 Particle/Hair collision with object

Any tutorials for using the new particles and hair collision? I have an object with particle hair and the hairs just go through the object. What way to tell the particles that the object is the collision object?

I have used a collision modifier on the object, but, that does not help. Particle hairs still go through object.

  1. Add sphere

  2. Create new particle system - set to Emitter “Hair”

  3. Turn on Hair Dynamics

  4. Move Object - setup keyframe moves

  5. Play - hair particles go through sphere

  6. add collision modifier to sphere

  7. Play - hair particles go through sphere

I’ve tried all parameters - damping, friction, etc. Nothing seems to fix issue

Thanks in advance

Hi all, since I have a related issue I may add my comments here.

I also tried to experiment with this new feature and did set up a simple test scene like it is shown and described here:

But the hair particles simply disappear when the colliding object hits them. This happened with 2.74 official and with the latest official version from the buildbot.

Then I tried the latest gooseberry version from the buildbot and in this the colliding object went trough the particles. So here the particle hair did not disappear - but it wasn’t affected either.

Maybe someone who has gone deeper into that new exciting feature can shed a light on that? Here is the blend file, if you want to have a look.

Thanks in advance!

OK, I have figured it out with the help of a blend file that plasmasolutions kindly provided in the YouTube comments of his great sneak peek. If you are interested in a working example you can download the file, which he provided, from pasteall.org:
http://www.pasteall.org/blend/35312

The solution have been the settings for the colliding object. You have to change the values in the red marked fields. After that it worked immediately or me:


@ernesttx, does this solve your problem also?

thanks for the tip. I knew it was related to cloth but before you mentioned i didnt try it out. Now it Works fine.

Thanks minoribus, I’ll check to see if that does help. I did play with those settings but nothing changed significantly. I’ll try those and let you know.

This is the video of how i achieve to the result i want: [video]https://youtu.be/PybAA2VG59M[/video]