2.75 Installation woes

I am having issues installing Blender 2.75a. (I uninstalled 2.74 previously, so I started with no installed version.) I first tried the .msi. The install wizard seemed to finish, but Blender was not installed. The folder I installed to (the default one) was empty, and Blender was not in my Programs list. So I tried the .zip version, which unzipped and ran perfectly. However, I am unable to associate .blend files with it because Blender still isn’t in the programs list. Choosing “open with” and browsing to blender.exe does nothing. I can open .blend files by running the .exe and doing file -> open, but that’s a PITA.

So I installed 2.74 again (without removing 2.75a). And suddenly I can open .blend files with either 2.74 or 2.75. I uninstalled 2.74, and I’m back to only being able to open via file -> open.

Long story short, I can’t directly open .blend files in 2.75 unless 2.74 is also installed, and the .msi version doesn’t install at all. What is going on?

I’m running Windows 8, using 64-bit Blender.

Just tell me at least how I edit skeletal mesh in 3d milk shape?

Blender is different than other programs (duh!) in that you can, and should, keep multiple versions on your computer. There’s no need to uninstall old versions, you just download the new version, and make a shortcut. The reason you want to keep old version is that it’s pretty common that the latest version will have some bug that makes your blend file created in previous versions crash or misbehave. So you always want to be able to go back. My toolbar right now has 5 different versions in it. I guess 2.69 Cuda can go.

Thanks for the reply. I usually limit myself to 2 versions (my uses are basic so it rarely breaks) since I dislike cluttering my hard drive. I’ve never had a version refuse to install completely though–I can’t be the only one experiencing this, right? I think the problem of not opening .blends from the .zip version is that I just can’t figure out how to associate the extension and the application.


When You use the Zip and run Blender first time…It make a temp folder in : C:\Users\YOURNAME\AppData\Roaming\Blender Foundation\Blender\2.75

It will be updated for every version You start…If You haven’t turn hidden file on You can’t see it…

I have Win 8.1 64 bit too…The only problem I have with assosiating is I have to do it every time I download a New Blender…:slight_smile:
I do it the same was as You say.


I think the updated filebrowser in Blender is pretty cool…Can see Font’s and icon now…:slight_smile:


The only problem I have with assosiating is I have to do it every time I download a New Blender

How did you manage to do this? When I tried the “Open With” option and browsed to blender, nothing happened. No errors, but the application never opened. And neither Blender nor .blend is in the list of associable software–unless I have 2.74 installed as well. If 2.74 is installed, I can work with 2.75 just fine. It’s as if they forgot to package something, but if that were the case I would expect to see more people unable to run it properly.

Sorry I don’t know why it do not work on Your Win 8

Here is what I do - Right click Blend file - Open with…Choose default program - click more options - scroll down - click look for another app on this pc…Browse to My Blend.exe - select it…And it work

I have never used the Blend install file…Only zip file…Made this test with a fresh build from today.


Yeah, tried that, it didn’t open. I tried installing on a Windows 8.1 machine today and it worked just fine from the .msi. So it’s either a Windows 8 thing or something messed up on my computer. Thanks for the suggestions, anyway