2.77 Stroke Sculpting mouse hotkey not working (pro'lly only on Linux)

I’ve been using 2.77 pre-release builds for a while, and today also tested the stable release, and have never gotten the Stroke Sculpting to fully work.

The default way to sculpt Grease Pencil strokes is to go into Edit Mode and hold E and draw with the LMB, much like D+LMB is used to draw the strokes in the first place. I can draw strokes just fine, but I cannot sculpt strokes at all.

If I hold E and drag, the stroke vertex nearest to the pointer gets selected and grab-mode gets turned on. No sculpt brush appears as intended.

But if I use the D+E pie menu for Stroke Sculpting, and click the Sculpt button to the left the brush appears just fine and I can sculpt as intended. It’s just the E+LMB hotkey that’s not working.

The shortcut, E+LMB is set in my configs, as it should be by default, but it simply doesn’t work. yet, the default D+LMB shortcut for drawing strokes is also set and works just fine.

The only other mention of this problem I’ve seen so far has been on a comment on the first Stroke Sculpting demo video. I don’t think comments can be permalinked to on Youtube; it should be the very first comment by ‘johan tri handoyo’ who replies to Aligorth that the shortcut isn’t working on 2.77 RC 1 on Ubuntu.

I am also on (X)Ubuntu 14.04, 64bit, and have used tested using builds from Thomas Schiex’ PPA, which is my main install, and the official 2.77 Linux build from Blender.org

Any help as to what I’m doing wrong will be appreciated.

At the moment, I can’t test the problem on other Linux or Windows machines very soon, so I’m looking for some confirmations and will report to the tracker afterwards: To recreate the problem, (on 2.77) simply draw any strokes with Grease Pencil, go into edit mode, and try to sculpt the strokes with E+LMB.

Mint, 64 bit here…
If by “edit mode” you mean Enable Editing button on toolshelf, GP tab, i am able to edit GP strokes using E key. Brush circle is visible if E key is pressed.
Blender 2.77 (sub 0), branch: master, commit date: 2016-03-09 23:22, hash: f65c08c

Just thought of a few other things you could try:

  1. Before entering sculpt mode, make sure you’re in object mode first. I’ve heard at least one report that texture paint tends to be problematic
  2. If you’re using the mouse, use a tablet. If a tablet, use the mouse.
  3. Try replace E with another hotkey - e.g. Q
  4. Try turning off the Pie Menus addon, just in case it is interfering. It shouldn’t though, since Daniel/pepeland uses that heavily, and he’s being able to use all this without trouble.

With number 2, at one point, I got into a strange situation once where midway through a session working with GPencil, I did mysteriously start having problems with E+LMB and/or the eraser - or at least that’s what it was, according to my notes. Unfortunately, that issue suddenly went away and never came back, so I haven’t been able to check further on it :confused:

I tried out the tests, unfortunately, to no avail:

  1. Made sure to be in Object Mode to draw strokes, and then used the dropdown to go into Edit Strokes mode.
  2. I had been using a tablet at first, and when it didn’t work had switched to the mouse. Some years ago some apps (mostly Inkscape, with a buggy non-Wacom tablet) used to misbehave on Linux when switching from mouse to tablet or vice versa, so today I tested out launching Blender entirely with mouse or tablet too. No change.
  3. Tried replacing the hotkey to Q (and turning Pie Menu off to avoid hotney conflict). Tried keyboard-only hotkeys too.
  4. Tried it with the Pie Menu turned off too.

Same symptoms as before: the sculpt cursor doesn’t appear, and instead the nearest point on the stroke gets selected.

I also tested out on a Windows machine and faced no issues. But then, eppo doesn’t have this issue on Linux either. Next week I will probably get access to some Ubuntu/Elementary desktops, and will try the tests again.

I tried out the tests, unfortunately, to no avail:

  1. Made sure to be in Object Mode to draw strokes, and then used the dropdown to go into Edit Strokes mode.
  2. I had been using a tablet at first, and when it didn’t work had switched to the mouse. Some years ago some apps (mostly Inkscape, with a buggy non-Wacom tablet) used to misbehave on Linux when switching from mouse to tablet or vice versa, so today I tested out launching Blender entirely with mouse or tablet too. No change.
  3. Tried replacing the hotkey to Q (and turning Pie Menu off to avoid hotney conflict). Tried keyboard-only hotkeys too.
  4. Tried it with the Pie Menu turned off too.

Same symptoms as before: the sculpt cursor doesn’t appear, and instead the nearest point on the stroke gets selected.

I also tested out on a Windows machine and faced no issues. But then, eppo doesn’t have this issue on Linux either. Next week I will probably get access to some Ubuntu/Elementary desktops, and will try the tests again.

I tried out the tests, unfortunately, to no avail:

  1. Made sure to be in Object Mode to draw strokes, and then used the dropdown to go into Edit Strokes mode.
  2. I had been using a tablet at first, and when it didn’t work had switched to the mouse. Some years ago some apps (mostly Inkscape, with a buggy non-Wacom tablet) used to misbehave on Linux when switching from mouse to tablet or vice versa, so today I tested out launching Blender entirely with mouse or tablet too. No change.
  3. Tried replacing the hotkey to Q (and turning Pie Menu off to avoid hotney conflict). Tried keyboard-only hotkeys too.
  4. Tried it with the Pie Menu turned off too.

Same symptoms as before: the sculpt cursor doesn’t appear, and instead the nearest point on the stroke gets selected.

I also tested out on a Windows machine and faced no issues. But then, eppo doesn’t have this issue on Linux either. Next week I will probably get access to some Ubuntu/Elementary desktops, and will try the tests again.

Scio : Do you have any solution yet? Or is it a bug? Anyway, i’m using blender-2.77-bac1279-linux-glibc211-x86_64.tar.bz2 and the sculpt stroke only works if you are using drop down menu, but not the shortcut. And also the brush circle doesn’t shows up in 3D viewport.


Well…what do you know. After several trial, apparently in Ubuntu you must create your own sculpt stroke shortcut to make it works. Just go to User Preferences and add new shortcut on 3D view tab.


Thank you for the solution Johantri! I still had the problem until I set the new 3D viewport shortcut like you suggested!

I searched the shortcuts for “stroke sculpt” and found that a shortcut already existed for me [Grease Pencil Strokes → gpencil.brush_stroke: E Left Mouse] in the same place as the draw strokes shortcut, but that one clearly has no effect on Xubuntu for some reason, while it works on Windows.

And I added the shortcut in 3D viewport, and it works!