2.79 shadow catcher


(fitz301) #1

I’m trying to use the new shadow catcher with cycles and an HDR environment map but there are no shadows at all.

Am I supposed to use a sun lamp with it because I can get shadows if I use one but the shadow color is wrong and unchangeable? I shouldn’t have to use a sun lamp if I’m using an HDR image for lighting; should I?

Is anybody else having a problem with the new shadow catcher?

-fitz


(English is not my native language) #2

Hi.
You can share a .blend scene here so others can see what exactly the problem is:
http://pasteall.org/blend/

I think it is not necessary that you pack HDR image in file.


(mib2berlin) #3

Hi, do you get a shadow if you switch shadow catcher off?
The HDR need extrem contrast to get a shadow anyway.

Cheers, mib


(Jason van Gumster) #4

Moved from “General Forums > Latest News” to “Support > Lighting and Rendering”


(sundialsvc4) #5

Although I frankly do not use Cycles much, I often render without shadows, then inject the shadows that I want using “shadow-only spotlights.” (The shadow information is captured separately so that I can adjust them further with compositing: once the spotlight tells me where the shadow is, I can control its density and tint.)

Shadow calculations are a big time-waster in (at least, BI …) rendering, and, while the shadows will of course be “exactly correct,” sometimes that’s a much harder situation to deal with than one in which the shadows are only “where and how I want them.” I can simplify the shadows while still keeping them at-least plausible … and save a lot of time.

In “real world” situations where I would have to dance-around with lights to eliminate unwanted shadows, in the magic-world of 3D I can simply choose not to generate them. Sweet!

Even if you’re using Cycles to do most of the work, you can also use BI’s shadow-spots (and/or anything else that BI offers) to provide supplementary information for final image-assembly which is done using compositing.


(fitz301) #6

Here are some screenshots showing the situation:


This is with just an HDR enviro map and the alledged “shadow catcher”.


This is the same scene with the “shadow catcher” switched off.


This is the same scene with “shadow catcher” switched on again and a sun lamp to create a shadow, which shouldn’t be needed if using HDR lighting, even with the shadow now the color is way wrong.

So clearly the “shadow catcher for cycles” doesn’t work in cycles.

-fitz


(burnin) #7

Hmm… works pretty well fine here.

e.g (IBL, Cube & Plane (set as shadow catcher))

& with Transparent Film ON!

Note:
HDRIs for IBL need to be fine (the more stops the merrier or you must edit/correct it - balance the sky VS the sun) :slight_smile:


(English is not my native language) #8

Not yet sharing a .blend file showing the problem… :spin:
If you decide to share that .blend file and you do not pack HDR image, also point to that HDRi link.


(fitz301) #9

What good would a .blend file do?

The scene consists of nothing but a cube, a plane, and an .hdr evironment map, any .hdr will do because I’ve tried several with the same results.


(English is not my native language) #10

People have already told you that they can not reproduce the problem. You assert that “clearly the shadow catcher for cycles doesn’t work”. So users can continue wasting time trying to figure out what your problem is, or you can share that “very simple” scene with HDRi used to better be able to analyze.

I had a guess about what could be the problem when very overexposed ground acting as emitter, but now even more confused because you say have tried it with other HDRi.


(Jason van Gumster) #11

It may have to do with how you’re setting up your file… or the HDR image itself. Sharing the file ensures that we’re all working from the same frame of reference.


(CarlG) #12

Just about all of my downloaded sun based HDRs are “broken” wrt having a way clipped sun level.
I have no problem getting it work as long as I make sure the sun strength is enough.
OP should:
#1 Increase brightness of HDR above a threshold, or
#2 Try the HDR burnin links to (assuming he’s getting the free “low-res” version to work).
#3 Upload file, an included “HDR” could even be a simple dark flat colored jpg with a bright area representing the sun, where the background strength is increased significantly (0.001, 0.001, 0.0025 and 1 1 1 at strength 100 becomes 0.1, 0.1, 0.25 and 100 100 100 - enough for a shadow I think). A link to the downloadable would also work.


(English is not my native language) #13

Hi CarlG.
I have a doubt that arose from this thread. Suppose all HDRi tested by ‘fitz301’ are the same kind of images, where ground (beach sand) is very overexposed. If that image is used as World environment texture, is that overexposed ground/floor emitting light, right?. In that case it sounds logical to me that shadow is weak or invisible. So when you just put a Plane in ground without shadow catcher, then the emission from the ground in HDRi is partially occluded and therefore it is possible to see the shadow in plane. And in the last example shown by ‘fitz301’, how strong the sun lamp should be configured so that it is stronger than HDRi light and shadow start to be visible?.
So for me this is not how Shadow Catcher should be used directly on the HDRi. You should put an image as Plane (backplates?) or something like that covering what is the floor of the HDRi.
And sorry if I’m wrong, just guessing. No file for testing and to see used settings.

And just in case, as always, sorry for my English :slight_smile: