2.8 Beta - No keyboard input at all

So, I installed 2.8 for the first time this week, and none of the keyboard shortcuts are working. Touching any key literally does nothing. Here’s my guess - the file that dictates shortcuts is not being seen properly. At my work, the computer nerds recently installed some new software that blocks most executable and .dll files unless they are specifically approved. Blender 2.80 wouldn’t work initially until that was approved by them (said it wasn’t “signed”). I’m thinking this is related, and the hotkey-file is being blocked, but I have no idea how to fix this, or where I would even go to start figuring it out. If anyone else knows what I could do, I’d sure appreciate any ideas.

If you open up an OS command prompt window and navigate to the folder where the Blender executable is and then execute:

blender --factory-startup

That should eliminate any dependencies on access to the config files in the default location on the system. But it’s possible that Blender is getting “sandboxed” to the point that it can’t read files in its own installation directories or something like that.

If you go to Edit -> Preferences, click the Add-ons section on the left, does it display a list of available add-ons successfully, or is the list perhaps blank?

1 Like

Good thought. I check the add-ons, and that list does populate, but if I click on any of them, I get an error. Despite the error, it seems I can turn them on (ArchiPack for example), but I can’t see if they work, since my Shift+A to add mesh doesn’t do anything. I will try the OS command prompt thing this afternoon.

EDIT - when the factory startup line is used at the command prompt, Blender starts up, but I still have no keyboard control. Hmmmm.

Did you check if the hotkeys you’re trying are mapped? Does zooming in/out in the viewport through hotkeys or mouse wheel work for you?

I ask because I’m also trying 2.8 and experiencing similar issues. I got the 1d908bffddb4 and 3d8cbb534f82 builds, and they seemingly didn’t come with hotkeys for most things. Even zooming in and out in the viewport isn’t mapped. I don’t know what’s going on. Since you can’t import keys from 2.79, I’m having a hell of a time remapping basic stuff.

Zooming does not work for me, and in fact, most mouse functions do not work either (even selecting/grabbing). In some places, some things work while others do not. I can drag a movement arrow or rotation circle and move the default cube, but I can’t click-select that same cube. I believe we are having similar issues, although it’s super weird it’s just the two of us. I’m just glad I’m not alone. :slight_smile:

EDIT: I’m trying to map some keys, and I notice my Keymap area is empty. Is this normal?

No, it’s not. At least I still have the necessary menus to map keys. I advise you to try to rename your 2.8 config/scripts directories at C:\Users{username}\AppData\Roaming\Blender Foundation\Blender\2.80 and reinstall 2.8. There’s a new version today. Didn’t solve my issue, but it might help yours.

I think it’s quite possible at this point that your environment’s security software is still preventing Blender from loading one of its DLLs or something like that. I would go back to your IT people and see if they can do anything to help.

Alternatively, try downloading the latest 2.80 Beta .zip file and extract it onto your desktop, and then inside the extracted folder there will be a 2.80 directory, and if you go inside THAT and make a new folder in there named Config then when you run blender.exe at the top level of that folder it will not need to mess with anything outside of that folder (will keep all its configuration, keymap, and startup files in that 2.80\Config\ directory you created). Then see if that behaves any differently. It will also be a fresh download to eliminate any possible issues resulting from the way your previous one was downloaded and installed. You can have as many versions installed like that as you want, and if you create the Config dirs in each one then they’ll be completely isolated from each other.

Finally got around to creating a “Config” folder, and it doesn’t seem to make a difference. When I started Blender after doing this, I got the home screen with the option to select my layout and color scheme, but the only option for the layout was “Blender”. And keyboard still does nothing. I’m thinking that if I had a proper .exe rather than running it out of the folder on my desktop, that I would have better luck, but it doesn’t seem like the Beta versions have any .exe files. Is there any way to turn the current beta into a proper installed version?

The “blender” in your unzipped folder is actually “blender.exe”, it’s just that Windows hides the file extensions from you by default. Normally there’s no advantage/difference between the “installer” versions available for official production releases like 2.79b and the experimental/zipped versions. However with managed windows security there may be restrictions on running software that is located outside of the normal software installation locations as an anti-malware feature.

Do you have 2.79b installed on this system successfully?

I’m assuming you don’t have administrator rights on this system? Possibly if you could move (or ask someone to move) the unzipped folder into C:\Program Files\ with appropriate permissions set, that might make a difference. In that case you would want to NOT have the 2.80\Config directory under there so it could use the normal system location for the config files I think.

I’m looking at whether I can build a 2.80 windows installer here.

1 Like

Ok, I was able to build a .msi installer from the current 2.80 source. Here’s a link if you want to give it a try. It’s not signed, so you might need to get an administrator to install it for you depending on how draconian your security environment is.


Note that this build does not have Cycles support for the new Nvidia 20x0 video cards because I’m lazy.

1 Like

This is great, and I really, really appreciate you doing this. Unfortunately, an unsigned installation file from someone I don’t know on a forum is exactly the kind of files my IT department hates, and won’t let me anywhere near. So, while I would like to buy you a donut because you’re awesome, I probably will realistically have to wait until 2.8 is out of Beta to use it. Oh well.
But thanks again - I appreciate your effort!!

I figured that might be the case. You can always get the source and build/package it yourself, it’s not that hard to do.

I’ll suggest that they build a Windows Installer version when we get to the Release Candidate stage if not before.

1 Like