2.8 CMD Line Rendering Gamma Node Problem

It’s me again :slight_smile:

EDIT: Oh well, if I run the same test on a different machine the results are as expected… I’m investigating…

Original post:

I need to render a landscape animation from the command line and with other scenes in the past everything worked as expected.

My terrain is created with a displacement map and when I render normally (blender with scene file open) I need to add a Gamma Node with value .45 to get the desired result, which is totally fine.

My problem is that as soon as I switch to command line rendering the terrain displacement looks as if the gamma stuff is acting weird. This of course messes up my displacement texture as well as the others.

To get the same displacement I disabled the Gamma Node which was applied to the displacement texture to get the same displacement amount. But as you can see the diffuse textures are off (didn’t disable their Gamma Nodes). And on another important note the sun is way blurrier than in the reference image. How come?

Is anybody aware of such an effect/limitation?

I’ve created a simplified scene that I can share showing the effect:

Scene: Gamma.blend (790.3 KB)

Gradient Texture:

If the scene is being rendered manually the result looks like this:

If is is being rendered over the command line it looks like this:

As you can see both the displacement texture (simple gradient saved as JPG) as well as the diffuse texture (same JPG) are altered through rendering with CMD line.

If I disable both Gamma Nodes, the result looks like this:

Displacement is fine. Diffuse, funny enough, is washed out as if it needed Gamma applied…

So if anyone has a clue on the Sun problem or the Gamma issue, it be really glad.

I figured it out, the one workstation was still running a beta version of 2.8. Installing the released version seems to have solved the problem.

1 Like