2.8 Extrude/Vertex Snapping Problem

(Aaron Stuart) #1

Hi Blender Artists community.

I’m sorry if this is a dumb question, but I’m new to Blender.

I’m building a millimetre perfect architectural model in Blender v2.80.53 on MacOS 10.14.4. I’ve been mostly using the extrude tool with Vertex snapping on to get the job done and it’s been working great. The model has grown (what I assume to be) quite large; 3482 verts, 6777 edges, 3267 faces, 6632 tris.

I have noticed some strange behaviour all of a sudden which is preventing me from continuing my work. I noticed I seem to be accidentally invoking commands with key presses. It may be that I’ve set some setting somewhere which is causing the problem.

The problem is with the extrude functionality I’ve been using. I’ve been pressing e to extrude a face, then I specify the exact length in the ‘Move Z’ field in the ‘Extrude Region and Move’ panel to achieve my accuracy. Rather than specifying the exact length, I may use Vertex snapping to set the length of the extrude. ‘Flip Normals’ is left off, Orientation is ‘Normal’ Proportional Editing is disabled.

What has started to happen is that I select a face for extrusion, press e, and the extrusion length appears in fields other than ‘Move Z’. That is, extrusion length appears in ‘Move X’ or ‘Move Y’. Sometimes, a seemingly unrelated length does appear in the ‘Move Z’ field in addition to the actual extrusion length in ‘Move X’ or ‘Move Y’.

Also, although the vertex snapping appears to be working (the circle showing which vertex will be snapped to is highlighting a vertex), the new extrusion does not snap to the correct length.

I’ve never seen the extrusion length appear in any field other than ‘Move Z’ and the vertex snapping has been bullet proof. Is this a bug or have a changed a setting somewhere?

Many thanks.

0 Likes

(Way) #2

Not sure, but to me it always looks like this. extude_last
Do you have a lot of custom settings? If not try to “load factory settings” (this will reset every setting to it’s default state).

0 Likes

(Aaron Stuart) #3

That’s how I’m used to seeing it too. I don’t have any custom settings really. I tried resetting to factory settings and I still have the same problem. This is how a standard 2.43m extrude looks.

01%20pm

0 Likes

(Aaron Stuart) #4

If I create a new object in the same file where I’m having the problem, the problem persists. If I create a brand new file and test my scenario, everything works perfectly again.

Seems like it’s a problem with that specific file. Is my file too big for Blender maybe? I’ll attach it for reference.Extrude - snap problem example.blend (1.0 MB)

0 Likes

(colkai) #5

1MB isn’t a big file, if anything, it’s tiny. :wink:
Your selected poly won’t extrude on Z, it’s natural extrusion path, (along it’s face normal), is gonig to be the Y axis. In this case I’ve extruded it along global Y axis initially. If you use normal, (which I’ve done for the second extrude), it extrudes along normal X, even though you may do e z z 0.5 and expect it to show in the ‘z’ axis, it is in the X axis, though during the extrusion it shows the blue line for the Z axis.

Personally, I don’t use the panel, but rather do it directly. So starting initially and working in global mode, press ‘e’ then ‘y’ then ‘0.3’ (or whatever length you want)

.

0 Likes

(colkai) #6

I did a small video, dunno if it helps at all.

0 Likes

(Aaron Stuart) #7

Thanks for your response Colkai and thanks for taking the time to make the video.

I understand what you’re saying about the Global orientation but the local does not make sense to me. I’ve spent hours working on my model and when the extrude functions ‘normally’ it extrudes on z axis every time regardless of the direction you extrude in. The X and Y values in the panel are always zero. Something went awry with the object I was extruding I think. You can verify this by testing in a new file.

I would love to know what has caused this behaviour of the extrude amount appearing in X or Y in the ‘Extrude Region and Move’ panel and random values sometimes appearing in Z. If anyone knows, please let me know. Possibly a bug?

My workaround is to blank out the amounts populated in X and Y. This wastes time but at least I don’t have to abandon my model. Pasting the object into a new file seems to have made my snapping work again too. I see this is a bug from Googling.

Thanks.

0 Likes