2.8 Light Bleeding?

Hi there,
I’ve run into a problem in 2.8 where, I try to do an interior scene - and the scene is lit up no matter what. Even if it’s a completely closed box. I am in rendered mode using Eevee. Also, if I add a sunlight outside this closed box; the light bleeds in through somehow. Am I doing something wrong? Is there a way to fix this?

Example image here:

Thanks in advance.

Switch to Cycles :wink:

More solid walls perhaps, or denser light sampling from the probes (where are they anyway?). I often see light leaking effects at work for those who work with rasterizing engines. I haven’t seen it once using path tracing.

But as I don’t use these myself, I’m no expert and I’m only guessing.

You can try enabling contact shadows on your lights and/or increasing the bias on your light’s shadow settings. Hope this helps.

I’m experiencing the same issue. Nothing I’ve tried has worked yet, and it seems some lighting features have been removed for Cycles (i.e. light intensity) or at least I can’t find them anymore.

So, it’s important to recognize what a shadow map is and how it differs from ray traced shadows while working with them. In basic terms, a shadow map is a depth based render of the scene from the light’s perspective. This then gets re-projected back onto the scene from the light. I don’t remember what the default resolution of those renders are (found in the render setting under Shadows) but very often it’s far to small. this is why they can look pixelated.

This is especially important when working with the default point light. A point light needs to render a 360 view of the scene so you can see how the resolution really matters when trying to make better looking shadows. Also, remember that these shadow maps get blurred or “filtered” which can exasperate the situation by eroding the shadow edges and causing them to look muddy.

  • In the case of the light spilling through the corners of the room, there are just not enough pixels to cover those areas and then those simple renders get blurred to simulate soft shadows. That causes even more issues. Try upping the resolution a lot to see if it helps. Also, try using spot lights or area lights when possible. Another issue might be that when the light is parallel to a wall, that wall will have very few pixels dedicated to it in the shadow map. So, try to avoid putting lights at glancing angles to large surfaces.

  • In the case of the cup above, It looks like the cup is penetrating the table. At the point where the table is inside the cup, there is no shadow for it. If you put the cup just above the table (just a tiny amount) should fix the issue. Also, I can’t remember if there is a Shadow Bias property in the light panel. If there is, try increasing or decreasing it and see if that helps. What it does is mess with the how the objects react to the stored depth value in the map and gives the impression that you are moving the shadow up and down under the cup.

2 Likes