2.8 Linux Multi CPU rendering

Hello everybody,

my slightly outdated (: graphics card cannot do GPU rendering. So I ask myself whether I could do multi CPU rendering with my xeon 8core. System monitor shows that only one CPU at a time is active.

Cheers,
Wolf

Well you should see how much tiles are rendering simultaneously in the render view. Check your thread count settings in the render tab.

Tks. Where can I find the thread count settings - never found them… ):
Is it that:

Cheers,
Wolf

It’s in Cycles rendering engine. In your screenshot you have Eevee enabled. In Cycles rendering, it’s in Performance section: Threads. Auto-detect should work, but you can try setting it yourself, and then observer eg. from taskmanagre how it behaves.

Windows OS might have some restrictions on multi cpu systems.

1 Like

Ah, yeah I should’nt have jumped so quick. What I said is only true for Cycles. Eevee doesn’t work that way.

Ah, understood. These settings apply for cycles only. So I’ll go for a more recent graphics card - CPU rendering is not longer state of the art.
Weird is that when I try to render a pretty nice car model, the system nearly completely gets blocked, even mouse pointer can no longer be moved. The same scene without that car model - no probs.
And no - it’s Linux, not Win**do…

Have you tried command line rendering? It takes the burden from drawing the GUI from your GPU and can give better experience in other activities during rendering. Now this might not affect you when rendering with Eevee but with your Xeon it might be a good idea to use Cycles and dial in the threadcount to two less than your max. That should give you a system, that renders in the background and is at least usable for e.g. browsing the web.
Edit: That car thing might very possibly be, that the scene with a car consumes a lot more of your RAM.
Edit 2: just out of curiousity, what do the ** stand for in your interpretation of Littlesqueezy?

Yes or simply lower priority of blender process, that should let your system more useable (i do that sometimes).

1 Like

Good point. I always forget those little optimization thingies since my system is beefy enough. But who knows how long that will last.
#fear-of-getting-outdated :wink:

1 Like

Thank you very much for your thoughts.
“Wintendo” used to be a common nick in the old days. Obviously it’s outdated now. Well, that’s how it is at your mid-50s. Everything is outdated.

Lowering process priority (using “gnome-system-control”) is a very good idea, I never used it before. Leaves the system usable - that’s great. To be honest: I would have expected Linux to protect the UI to get completely disfunctional… But anyway, thus we can deal with it.

#fear-of-getting-outdated
I never have that. Always buy 2nd hand hardware, than you know you ARE outdated - and the fear is gone. Try - it really works.
:wink:

Hahahaaaa, Wintendo is cool! I’m no English native so that one didn’t cross my way. But I like it.
Glad you got your machine into usable state.
#memestuff:
I just realized that I wanted to do a joke in relation to classic heavy metal and should have better named it #666-fear-of-the-outdate.
Never mind of old hardware. I was outdated untill last year and probably will be again for quite some time when we reach next year’s fall time. I’m also in that camp of people without a goldmine under their basement.

Now I upgraded with an really outdated GTX 650 graphics card (1 GB of RAM only… ): ) , CUDA is enabled now, but result is that

  • UI is completely unresponsive when rendering, even if priority is set to “very low” in gnome control centre, or I launch blender with “nice -19”; top’s “load average” readings range from 10 to 16!!
  • cycles rendering reliable crashes, eevee only works

I found a strange RAM issue - top and gnome control center report only half of RAM which is physically installed - and what dmidecode show:

https://ubuntuforums.org/showthread.php?t=2428996

I’d really like to know whether I’m actually working with 6 or 12 G of RAM.

Cheers,
Wolf

Your system will use only as much RAM as it needs for the processes running.

The 5.8GB available are available because they are not currently being used, it doesn’t mean the other 6GB cannot be used.

Try:-

cat /proc/meminfo

Does it report the correct total amount of installed RAM?

1 Like

Attention! Minor nerd gripe ahead.
Unjustified use of cat. Use less instead.
Sry, couldn’t resist. :smile:

This is what /proc/meminfo says:

MemTotal:        6037884 kB
MemFree:          152952 kB
MemAvailable:     912572 kB
Buffers:           91800 kB
Cached:           956696 kB
SwapCached:       139140 kB
Active:          4318248 kB
Inactive:        1025976 kB
Active(anon):    3920220 kB
Inactive(anon):   501560 kB
Active(file):     398028 kB
Inactive(file):   524416 kB
Unevictable:         160 kB
Mlocked:             160 kB
SwapTotal:       4194300 kB
SwapFree:        3126412 kB
Dirty:              1924 kB
Writeback:             0 kB
AnonPages:       4265332 kB
Mapped:           584308 kB
Shmem:            126004 kB
Slab:             183676 kB
SReclaimable:     100528 kB
SUnreclaim:        83148 kB
KernelStack:       20752 kB
PageTables:        73184 kB
NFS_Unstable:          0 kB
Bounce:                0 kB
WritebackTmp:          0 kB
CommitLimit:     7213240 kB
Committed_AS:    9440544 kB
VmallocTotal:   34359738367 kB
VmallocUsed:           0 kB
VmallocChunk:          0 kB
HardwareCorrupted:     0 kB
AnonHugePages:         0 kB
ShmemHugePages:        0 kB
ShmemPmdMapped:        0 kB
CmaTotal:              0 kB
CmaFree:               0 kB
HugePages_Total:       0
HugePages_Free:        0
HugePages_Rsvd:        0
HugePages_Surp:        0
Hugepagesize:       2048 kB
DirectMap4k:     6019072 kB
DirectMap2M:      206848 kB

Looks as if 6GB of RAM only were available. Should I swap around RAM bars?

You could. You could also start the machine with only on stick and see if it boots at all, to determine the broken one. You might also consider to run memtest from a usb stick and see what it reports.

Good Point!

Looks as if the 2x4G pair is more sort of than really the same. Different frequencies…
I LOVE 2nd hand hardware… :face_with_monocle:

And AFAIK I cannot set RAM timings in BIOS, didnt find any controls…
:cry:

But lshw -C memory

says that all do the same timing:

 *-memory
       Beschreibung: Systemspeicher
       Physische ID: 30
       Steckplatz: Systemplatine oder Hauptplatine
       Größe: 12GiB
       Fähigkeiten: ecc
       Konfiguration: errordetection=multi-bit-ecc
     *-bank:0
          Beschreibung: DIMM DDR3 Synchron 1066 MHz (0,9 ns)
          Produkt: M391B5673FH0-CH9
          Hersteller: Samsung
          Physische ID: 0
          Seriennummer: 8551F387
          Steckplatz: Slot-1
          Größe: 2GiB
          Breite: 64 bits
          Takt: 1066MHz (0.9ns)
     *-bank:1
          Beschreibung: DIMM DDR3 Synchron 1066 MHz (0,9 ns)
          Produkt: 9965525-033.A00LF
          Hersteller: AMD
          Physische ID: 1
          Seriennummer: D23E7199
          Steckplatz: Slot-3
          Größe: 4GiB
          Breite: 64 bits
          Takt: 1066MHz (0.9ns)
     *-bank:2
          Beschreibung: DIMM DDR3 Synchron 1066 MHz (0,9 ns)
          Produkt: M391B5673FH0-CH9
          Hersteller: Samsung
          Physische ID: 2
          Seriennummer: 8551F3F2
          Steckplatz: Slot-2
          Größe: 2GiB
          Breite: 64 bits
          Takt: 1066MHz (0.9ns)
     *-bank:3
          Beschreibung: DIMM DDR3 Synchron 1066 MHz (0,9 ns)
          Produkt: 9965525-032.A00LF
          Hersteller: AMD
          Physische ID: 3
          Seriennummer: AE0ED5A9
          Steckplatz: Slot-4
          Größe: 4GiB
          Breite: 64 bits
          Takt: 1066MHz (0.9ns)

… what I’d have expected. Yessss, these are the troubles I really love.

Some motherboards don’t support mixing memory that runs at different speeds. Maybe try pulling out the slower one and see if that adds up to 8GB, and/or try booting with only the slower one.

EDIT - Actually, that won’t make sense if it’s reporting 6GB as they would have to be in the wrong slots as well - ignore this bit . . .
If the speed mismatch is the problem you might find it doesn’t boot at all with just the two 4GB sticks, but will boot with either one on it’s own.

(If it’s dual channel it might ignore both slots?)

1 Like

In the meanwhile, I threw out 4G and gained 2G of usable RAM. :roll_eyes:
Seems the system does not like one 1066 and one 1333 MHz bar together. Now I’ll see whether I can obtain suitable RAM.

1 Like