2.8, No compatiable GPUs found for path tracing? GTX 1080 ti?

Blender 2.8 build 2019-06-11. Blender sees the two GPUs in my system, but Cycle is not using them. Am I missing something in the set up?

Windows 10 Pro 64 with latest Nvidia driver. BTW, I’m using Nvidia Studio Driver instead of standard one.

image

image

image

How exactly have you seen that they are not used?

Edit: Did you actually enable GPU Usage in the render settings?

Your display is correct. You should select CUDA and then all the available devices. There will be no available devices under OpenCL for an Nvidia setup. Leave it set to CUDA.

You will of course also then need to enable GPU Compute in the Cycles render properties.

For the sake of completeness: NVIDIA cards are able of OpenCL computing. But it takes special drivers and isn’t worth the effort since they perform really bad under OpenCL.

My bad, Blender is using both GPUs & CPU in Cycles, even when I set to GPU compute. Interestingly it’s only using 2 out of 12 CPU cores.

@chalybeum My CPU cooling system has a pair of mini leaf blowers that go off whenever CPU is running at full load. That’s why I thought it was running on CPU only. But why does OpenGL settings states Cycles will be render on the CPU?

@ Zoot Thanks for the confirmation.

I’m still not used to 2.8 UI yet, but I’m loving it. Where are all the fine tuning settings for GPU like 2.79 has?

Sry, I am more confused than before. Is your problem with CPU or GPU?
When ticking the checkbox under Cuda settings for the CPU. It will render alongside your GPUs when GPU compute is enabled in the render settings.
If you choose CPU there the cards won’t be used.
Leaving the CPU checkbox under Cuda settings unticked will only use the both cards.
Cycles doesn’t render with OpenGL. At least to my knowledge. However the Viewport and UI is drawn by OpenGL.

Oh I got it now, thanks for the clarification on CUDA settings. I’m still on 2.79 mindset and it has been a while since I used Blender. 2.8 lets us use CPU & GPU simultaneously for Cycles whereas we couldn’t before, it was either GPU only or CPU only in 2.79. I also got confused by that warning “Cycles will be render on the CPU” in OpenGL settings.
Thanks guys.

Cool, glad you found your way through it.

Anyways, to avoid future confusion:
The settings under the user preferences > system are for OpenCL, not OpenGL. They are fundamentally different things.

1 Like

Pretty much all the same tuning options should be there, though a few may have moved to other tabs. Most are in Cycles Render Properties (just like 2.79 where Blender Internal was the default you need to switch to Cycles of course before you’ll see those settings).

Note that the 2.79 experimental builds (available from the same place you downloaded 2.80) have exactly the same version of Cycles that 2.80 does, with the same performance and options (new nodes, CPU+GPU rendering, etc).

2 Likes

@chalybeum I didn’t even notice it’s OpenCL, the whole time I was reading it as OpenGL. I need a new pair of glasses. lol

1 Like