2.8 Not working properly on my MacBook Pro 2018. not able to orbit or select with the trackpad

Every since I tried to install an addon called “extreme PBR” from the blender market, that didn’t download as a zip file, but just as a folder, I started having problems with my blender 2.8.
The problem started right after I hit install from file on “extreme PBR.”
Since then
Those problems consisted of not being able to orbit around my mesh using the 3rd mouse button or two fingers on my trackpad, or even select the file in the addon section of “install from file.”
And it seems no matter how many times I uninstall blender 2.8 and reinstall it, It still doesn’t seem to work.

And when I hover over certain options in Blender 2.8 a quick popup comes up that says internal error.

Someone please help me get usage of my Blender 2.8 back.

Have you tried loading factory settings? Uninstalling doesn’t remove all of the user preferences, so it can just load everything back when you reinstall.

Yeah, I tried doing that. Nothing changed.
I recorded my screen of me trying to use it. How would I upload that to hear?

Here’s a link to a screen recording that I did.

I can move the scene around via the on screen controls. But when you see my mouse move on the 3d view screen, I’m actually trying to move the view around with my two fingers on the trackpad, like I use to be able to do. But it doesn’t work.
And when you see my mouse hover over the camera, I’m not even able to select it with the left click button on the trackpad.
And then you can see when I go to preferences, and then go to desktop, for some reason I can’t select a file.

I get the exact same problem. Brand new Mac Pro, Fresh Blender install. I can click in the interface but I can’t drag anything. And in the prefs, for Cycle, I don’t see the graphic card. I don’t think it’s a trackpad problem. Unless it works for you using a mouse?

I guy , solve the problem?

I filed a bug report

We have seen that this problem is known about blender 2.8, the best thing is to do the bug report.
Can i see the bug report link?