2.8 Texture paint rendered display

I’m trying to paint a texture in Blender 2.8 with the final material previewed in the 3d viewport but it only displays the current texture. Man, its frustrating to have to hunt down stuff like this. Anyone able to help? Thanks.

I’m having the exact same issue. I’m trying to do something like this: https://youtu.be/ktsyL2Kp5bQ (skip to 20:00 for bump mapping), but there’s no “material” view in 2.8. So whenever I’m in Texture Painting mode, it looks like this:

While the final result looks like this:

I’ve tried Look Dev and Rendered view, but there’s no way to preview it without switching to object mode.

Switch to “texture paint” mode. Switch to eevee (rendered). Overlays > opacity set to 0.

1 Like

Yessss!!! Thank you, it worked!

Good to know… thanks!

Thanks for this! This setting seems out of place. Seems like a texture paint option… I’ll have to look and see if there are any UI discussions about this.

my problem is the other way around

the overlay feature seems to be not working at all anymore?
is thats so? Or am I missing something

Your image texture isn’t plugged into the color socket though.

thank you for your assistance craig

I am not sure if I maybe expect a behaviour that indeed was more a bug than a feature in previous blender releases

I really see this slider have influence on behavoiur
but like its tooltips says sololy on “textur paint mod stencil mask overlay”

there is a youtube tutorial of Grand Abbitt
https://youtu.be/zdd0kVanSLM?t=130 at this very moment we can see the feature - i was originally expecting - working

I already commented on this issue

so just to be double clear

this feature is broken now ?

That is intentional change:

and now in master/buildbot/2.81 “Opacity” is called “Stencil Opacity” to avoid confusion.

thats a very competent answer
I thank you deeply for releaving my struggle with this