2.8; Texture painting - not painting


When I try to paint textures (stencil) onto my model I can’t do it from 3D view. When I paint there nothing appears on the model. I assume maybe I don’t have the “canvas” texture selected, but I don’t know how to select it. Working from UV view is useless because I need the warping.

Funny thing is - a few minutes later it works in the 3D view too. Then I see that I’m actually drawing on the wrong layer;

I want to draw on a new image so that I can tweak the image separately. How do I select the image that I am drawing on in the 3D view? And why does it sometimes not paint?

This happens far too often for it to be a bug - I am definitely missing something obvious.


Try using “image” mode instead of “material” mode for texture painting. You can set this from the 3D toolbar, slots tab. Then set the image you want to paint and the UV map you want to use to paint it.

Blender tries to be smart about what you want to paint for material mode. It is, apparently, smarter than I am in this regard. I always set it to image mode instead to make it actually do what I want it to.

Not sure it’s relevant but I’ll mention there’s a bug in 2.80 that prevents easily painting on top of subdiv/multires type surfaces as the brush sees the un-transformed vertices rather than the visually displaced ones. As a workaround you can turn off the modifier in the viewport so what you see is what the brush tool will act on.

Thank to both of you, It’s been a breeze now.

Bandages’ suggestion was what cleared a large portion of my problem, though the actual reason the drawing didn’t appear was that I hadn’t selected the part of the model I had to draw on. It doesn’t feel like this is the proper way to do things because it feels cumbersome, but I had to switch back to a different window to select a different mesh, then back to the texpaint tab and continue to paint.

I haven’t had the situation of drawing over subdivided meshes, but it is good to know.

Regardless, it solves my problems. Thank you!

1 Like