2.8 viewport performance

Blender 2.8 viewport performance is low.im getting 25 to 30 FPS max,if i disable overlay completely viewport become smooth 60FPS.
Spec:i3,HD 5450,4 gb ram.

Do you mean with “disable overlay completely” the Interface->Region Overlap setting?

Even in just the default scene, or how complex is the scene that’s giving you poor performance? Is 2.79 better for you?

That’s a relatively low-end video card these days (introduced more than nine years ago) and is probably on the edge of being unsupported in modern Blender.

yes disable overlay completely

Yes default single cube scene

I don’t see any changes when I deactivate region overlap.
Whether enabled or disabled I always have just under 10 fps in my test scene
Windows 7 - GTX 1070

Edit:
Oh, no, OVERLAYS… Damn it.
Those who can read have a clear advantage.
I should have stayed in bed today.

P.S Unfortunately I also don’t have a performance boost with disabled overlays in object mode.

I’ve got a huuuuuge performance boost in sculpt mode when deactivating overlays!! :slight_smile:
In Object mode speed is always good for me with overlays.
(GTX 1080 Ti)

1 Like

I see no apparent difference in viewport rotation feedback on a 1060 with a million poly sculpt turning overlays on and off. Is it navigating the viewport or actual sculpting that’s slow, and if sculpting does it matter what brush/more etc.?

Anyone else having this issue please give as much info as possible. If we can narrow it down to something specific then a bug can be entered for it.

Does your system also have Intel integrated graphics active, and are you sure Blender is running on the 1080? If this is Windows, can you find the Blender.exe file and right click on it and see if you have a “Run with graphics processor ->” menu and whether selecting the 1080 in there makes a difference?

It is only recognizable while sculpting (brush doesn’t matter) as well as undo-speed for some reason …

Hmm, I don’t have “Run with graphics processor” in my right click menu.
But I can choose the 1080 in the preferences for rendering Cycles so Blender should be using it, I guess.

image

Yes, that applies only to Cycles when it’s rendering and does not have any effect on viewport / sculpting etc. which only depends on which video card Blender is using for its UI / OpenGL.

How polygon heavy are the models you’re sculpting on? Dyntopo mode on or off? Are you using a current 2.80 build?

I had this in every build I tried, also builds from a few days back.
the model I tried it with today had around 2 million points and it is slow with dyntopo on AND off.

There is another thread with people experiencing the same btw.: