2.8 visibility problem

Hello, while importing an image as reference and then adding a cube,it became transparent. How can i resolve this problem? Thanks!


I’m having this problem only in my p.c. (geforce gtx 780). My laptop is working fine.

Select Reference object.
Take a look at “Object” Tab in Properties editor.
Open “Viewport Display” panel.
Uncheck “In Front” option

Thanks zeauro,
the “In front” option is unchecked and the cube is still transparent.

I replied too quickly.

An Image Reference has special setting under its Object Data tab.

Check Depth setting.

1 Like

Which operating system?

windows 10

so you think that the cube transparency is related to the image reference Depth?

Are you using the latest version of 2.8?


If the problem is not related to what zeauro recommended (the same .blend file works on your laptop but not on your PC), you try downloading nvidia driver from nvidia drivers site and doing a new clean installation of the driver (the interface of installation has an option to perform a clean installation, I do not remember exactly the name)

Yes YAFU. The strange thing is that i don’t have this problem while using the same version with my laptop…

Does this happen with exactly the same .blend file that contains the packed image?

Ok, thank you both. I’ll try to follow your suggestion.

Yes it’s the same file

The problem was fixed. I’m so happy :slightly_smiling_face:
Zeauro, you were right. It was the image reference Depth.