2.81 Major Issues on OS X High Sierra

Hello, I’m having a hell of time trying to figure what is going on with 2.81 on my system.

MacPro Mid 2012
High Sierra 10.13.6 (on 500GB SSD)
3.33 GHz 6-Core Intel Xeon
16 GB 1333 MHz DDR3
AMD Radeon R9 280X 3072 MB

The main issues are my objects in Material Preview and very often Rendered View keep going completely invisible within a minute or two of working. And, I can no longer select them by clicking on them. I have to box drag select or click on the model in the Collection. It is so bad that I can’t use the program at all and I have no idea what is causing this. Nothing like this happened in 2.8 which I have been using daily. The objects show in Solid View, but Material Preview they just go invisible and usually, but not always the same in Rendered mode. I have tried eevee and Cycles, Rendered view sometimes shows the model in Cycles, but eevee nothing.

I can see and move my lights, however the models whether imported or created, just disappear from the Viewport, but are still there.

At first, I thought it was an imported OBJ that I created in another program that was causing this, but now it happens with a brand new file with the default cube. I have tried resetting to factory defaults and not installing any of my purchased/included Addons, and did a system restart and reset my PRAM. I have also tried Experimental, GPU/CPU to see if that does anything, no difference.

I’m sure something this drastic must be dependent to my specific system, but again, everything worked fine in 2.80. I love this program so I don’t mind going back to 2.8, but for these types of show stopping issues I’m really confused as to what is causing this in 2.81? Are there any type of prefs/plist I can find and delete that are generated by Blender?

If anyone has any suggestions please let me know. As mentioned, I am forced to go back to 2.8 which is not a big problem for me, but I sure would like to use the new features in 2.81, and more importantly figure out what the hell is causing this. It would be great if anyone else was seeing this on OS X, but my searches haven’t turned up anything here or on Google.

Any help or suggestions would be greatly appreciated, thanks all!


I’m getting the same thing on 10.14.6 Mojave. Switching to Material or Rendered view will break selecting objects as well as Edit Mode. I won’t be able to select or edit verts/edges/faces anymore. I also sometimes get the invisible objects. Seems like the main problem is the Shading workspace. I can reliably reproduce the problem there, but usually fix it by switching back to Layout/Modeling/Sculpting and reselecting objects.

Thanks for confirming similar issues, Bachus. Do you mind posting your machine specs?

iMac 27-inch, late 2013
MacOS Mojave 10.14.6
3.5 GHz Intel Core i7
24 GB 1600 MHz DDR3
NVIDIA GeForce GTX 780M 4 GB

Thanks Bachus, it looks like this is confirmed by the developers (at least the disappearing issue).


Not sure about the inability to select objects, still looking on the bug list to see if it has been reported.

Everything in that bug report is exactly what I’m seeing. The broken/invisible rendering, wireframe object outline with no actual wireframes, no selecting of meshes, and the zoom/move/camera gizmos disappearing.

Latest 2.82 Alpha has fixed the issues we were seeing. I see some weird lighting ray and render artifacts on my model in Cycles and Eevee, but other than that, the main bug seems to be gone!