2.81a version sometime "crash" when i do undo?

Hello guys im new in Blender,
does someone have this issue also?
Sometine in different time intervals when i make model and need undo the program get closed without error message?
Should i use the 2.79 version is that good idea?
Spec:
I7 7820x
64 GB RAM
RTX 2070 Super
Win 10/64
Everythings is update.

I’ve experienced most of my 2.8x crashes when doing undo / redo actions. I’ve just into the habit of saving often. 2.8 has more features than 2.79, but for sure, the latter is more stable on undo.

Yeah, need to save often, i thought this bug was fixed :confused:

I haven’t experienced crashes myself, but then again I’m using 2.82 dev (which got some undo related commits) on an M.2 drive.

Bastien has been working on a branch known as undo-experiments, in it he is working to make undo operations faster and more stable.

No crashes with undo using 2.80 or 2.81a lately.
Not a good idea to revert to 2.79 in my opinion.

Are the crashes when undoing specific commands? Some add-ons have issues handling undos. For example Archipack, i had more trouble with 2,79 with that…

I experienced crashes on undo in object mode. I found that in my case they were caused by the bug in workspaces. The bug was fixed at some point before 2.81 release, but I saved a startup file before the fix, so I had a bugged save files and every time I loaded blender I had bugged workspaces in my scene. This sometimes led to crashes.
Here’s how you can check whether your save file is bugged or not:
Navigate to Data API in Outliner and check screens in workspaces
Every workspace should have only one screen and screen name should match workspace name
So this is good https://i.imgur.com/0jOUqnK.png
and this is bad https://i.imgur.com/cbIrInL.png in my case that was the cause of crashes

If you have a similar issue in your startup file or savefile, then you need to delete workspaces in it and append them from a clean startup file which you can get from File - Defaults - Load factory settings

4 Likes

Thanks a million, mate. You’ve saved me from throwing the computer out the window. :laughing:

I worked 10 hours yesterday modeling in 2.82 and it crashed 80% of the time I hit ctrl+Z. I was saving before every single modeling operation.

Cleaning out the workspaces and appending them from a clean startup seems to have worked. I’m coming from 3dsMax so I’m unfamiliar with what Blender is doing ‘under the hood’. Can you tell me WHY this is happening? Why are these garbage workspace screen duplicates being stored? I’ve had similar issues with garbage meshes in the data api. Pity there’s no way to delete these workspace screens directly in the data api list. Thanks again.

Thank you I had a bugged workspace as well after testing several alpha/beta Versions.

Is this bug related to the one where the console will put out an error message. I can not remember the exact wording but it was something like:

error: can not find region with ID 2 in ‘Graph’

or something similar

As I understand it was due to buggy startup file that was shipped with blender 2.80-2.81. It was fixed at some point of time, but in my case I used that buggy blender version and saved buggy workspaces into my startup file and some blend files, not knowing about it

Looks like most of these bugs have been fixed (?)
https://developer.blender.org/T69974
https://developer.blender.org/rB51b2d06613bb3a11a04f051d7dabaa6530a0e5c0
https://developer.blender.org/rB1f1d302950044592b8812c022897abfc838580a4
https://developer.blender.org/rBSf2dc78f13fb7aa7af02828ec42d8ecf030d7b2a5

But fixes are only to default startup file and if you already have a corrupted file, they don’t work on it. If you have buggy save file, then you need to open it without “Load UI”

All these are just my assumptions, what really happens is known only to developers.

I reported this bug, but they closed it saying that

“Could have been during the fuzzy filebrowser changes era e.g., there were some issues with screens/workspaces at some points iirc.” https://developer.blender.org/T69519#787227

Maybe, I don’t know for sure

2 Likes

Sounds about right. Having cleaned out the workspace screen garbage I’ve been working for the last few hours without a single crash. Thanks again. You’ve been very helpful.

Damn, it seems new custom workspaces often became buggy and better not to create them at all and use only default ones. Otherwise blender will start to crash on undo after some time. I’ll try to publish a new bugreport, hope this time it won’t be closed

What kind of M.2 drive are you using? Just thinking planning on buying one, not sure if it’s worth it or how much faster saving/undo will be. Blender and zbrush saving times are killing me atm, files between 5-10gb, takes ages when autosaving for example. I’m eyeballing with a corsair one, about 4-5gb/s r/w.

It turned out that crashes on undo are fixed in 2.83. At least I can’t reproduce them on latest build

1 Like

I’m getting the same instant crashes again on 2.83. I’ve checked for garbage workspaces in the data api and there are none. The undo buffer is completely broken and just instantly closes Blender every time.

It’s sad to hear. In this case I don’t know what else to advise other than saving a copy of scene and deleting workspaces one at a time, starting from your primary and executing undo to find a broken one.

I suggest you to open a bugreport (blender “Help” menu - “Report a Bug”). Here are my past
https://developer.blender.org/T73705
https://developer.blender.org/T69519
You probably need to attach your file there (It does not have to be full scene, I was able to delete all meshes from my save and purge orphan data and crashes were still reproducable).

1 Like

This nightmare continues in 2.90. Maybe it’s my startup file? Maybe it’s 2.90 being beta? Maybe the undo system is f**ked?

Edit: disabling global undo seems to have helped.

Edit 2: disregard edit 1. Still happening. Almost instant crash every time I hit undo a few times. My startup file must be severely corrupted.