2.9 - I can no longer click-drag select

For some reason, in a few important Blender files I’m trying to finish, I can no longer use Click-Drag to select single or multiple faces, edges, etc. When I click and drag (with Shift or not), the faces are in x-ray while the mouse is down, but on release nothing selects. I can still select face-by-face, edge-by-edge, etc., but I can no longer use click-drag over a mesh to select.

Has any encountered this before? It is not my configuration, because in some files it works. Must have hit a combination of keys or something.

Thanks for any help.

You’re playing with fire using 2.9 in production. It’s also difficult to check because you didn’t provide the version hash and if it’s not today’s nightly, it can’t be downloaded unless someone happens to have a copy. It has to be compiled from source with that hash checked out

It’s probably a temporary issue with one commit interfering with another.

Good point. Thanks.

What if you use the shortcut B for box select

I tried that. It’s odd. I’ve tried many different things, but nothing yet works. Can’t tell whether this is a bug in 2.90.0, or just some combination of keys I hit by accident.

What if you use Alt + A deselect all

Tried that too. Thanks for making suggestions, though.

1 Like