2.9 Problem whith numerous linked objects

Hi all :slight_smile:

I just switched to 2.9 ! and am proud of it though somewhat deceived :confused:

With 2.79 my scene took 30 seconds to load…
With 2.9, it’s now 25 minutes and ait’s still eating 100% of a 16 threads CPU…

Is this a ‘feature’ so that i learn play freecell ? :rofl:

Now that i switched to 2.9, what will devs do for correcting this feature that makes blender simply unusable ?

Happy blending !

EDIT:
forgot to mention: eating 16GB ram ( while 2.79 was only at 5GB^^ )

Hmm… sounds strange. Perhaps there is some corruption. Have you tried appending the whole scene instead of opening the file?

Now that i switched to 2.9, what will devs do for correcting this feature that makes blender simply unusable ?

They won’t do anything if you don’t report it as a bug and include steps to reproduce it and you maybe even need to include your file for testing. This is the same for all apps, if the devs don’t know the problem they can’t fix it, nothing get fixed by complaining in a forum not related to the actual development.

6 Likes

Thanks a lot @Ztreem for your precious help !
I’m this stupid i didn’t even think about bug reporting with my 500+ files ‘rared’ in a 4.5GB project attached !

@Lumpengnom Indeed it is strange :sleepy:
I guess it’s not a corruption problem because this happens with all my files :confused: ( or in this case, all my files are corrupted; wich could happen ^^ )
I use many files with objects linked from other files and each object carries 4 UVs with bit textures.
Some textures are 8Kx2K and some others are 8Kx8K.
The strange part is that all object share the same textures.

The behaviour is kinda strange too:
File loads properly ( i saved it in solid display ) and quickly.
But when i switch to texture display in 3D view, blender starts its mem eating up to my whole mem ( and above :stuck_out_tongue: ) with the CPU jumping from 100% to 0% and back to 100…

I think i’ll have to spend the day digging in this…

Happy blending !

Well, the texture display mode is now actually a type of EEVEE viewport and shows a more complicated image, so that could explain the memory but I dont think the loading times.

Have you tried saving the file in 2.9 and then re-opening it in 2.9? Perhaps it is doing some sort of conversion stuff on the first time openng it.
But yeah, what about appending?

So is this in 2.79 or 2.9? Does it load quick in 2.9 but it takes time when you activate texture viewport?
Do you use eevee or workbench?

@Lumpengnom yes i saved and reopened in 2.9 and blender behaves the same: long times to display in textured mode, even with all linked objects shown in wireframe ( as solid do not work anymore ).
Appending to a new scene changes nothing to this.

@Ztreem It’s in 2.9. Yes the blend loads quickly ( i mean it’s a normal time compared to 2.79. it’s about 20 seconds ). And yes it take ages and Gigas when clicking on the texture preview mode in the 3D view.
I use cycles. not EEVEE nor workbench as i don’t need to render scenes. I only need to edit meshes and UVs.

I think that it uses Eevee in viewport even if you have cycles as renderer if you are in this mode.
blender_20201019_7470

I’m not sure, but I think workbench is faster and more similar to the 2.79 way, try and see if it’s faster.
blender_20201019_7472

Texture preview and workbench are EEVEE modes. They take longer to display than the 2.79.
This is not a bug.

hey guys :slight_smile:

I’m making a long reply and be there soon :wink:

Yes the 3D view is EEVEE. Even if IMHO this is a very bad choice it’s users fate decided by god :rofl:

The workbench would be just perfect to me if it could show real material preview just like 2.79 did with GLSL. But unfortunately god had choosen only solid and wireframe ( and in its great goodness, bounding box :joy: ) display options. It’s okay for modelin but a bit useless for unwrapping/texturing.

Anyway… i be back very soon somewhat ashamed/questionning… :slight_smile:

Happy blending !

Here i am.

I stripped my whole project as much as i could so that i disclose the least of the project ( please don’t spread the files ) but so that my problem still appears when a file is opened in 2.9

Do not try to open them in 2.79 as files all come from 2.9.

As a quick sumup of the project, i’d say: it’s a medieval city intended to be visited in a 1st person manner ( meaning lots of details ) wich is cut in walls/towers/citygates.
each wall/tower/citygate is a separate .blend ( simplified on purpose as in my project each blend have objects surrounding the one the file is about. Thos surrounding objects come from other .blend that are linked in the file ).

For baking purposes ( emission for nighlight maps ) i need to include in one unique file, all the objects coming from different .blend

This is where all my work is fucked up: Though opening the file when displayed in solid or wireframe takes 25-30 sec, as soon as i choose the mat preview in the 3D view, blender freezes and eats all my memory and part of the CPU power.

The whole scene takes more than 2h and more than 32GB to load ( i didn’t even wait till load ends and killed blender before it finished :stuck_out_tongue: )

A stripped part of my project showing the problem ( say in a sandbox ) can be downloaded and tried here:
http://kleioscope.fr/temp/Carcassonne%20libs%20problem.rar
Just browse to ./carcassonne libs problem/meshes
and open the carcassonne_lice1.blend

The file opens quickly as its display mode is solid.
Now just switch to mat preview mode and watch at your system memory availability.

I guess you can go to the end and finally display the thing but imagine the same thing with 30 or 40 times mode items :smiley:

This is just unusable.

I found a workaround to this problem in 2.79 by making objects that i didn’t want to appear with mat preview show in a solid way. This prevented blender from loading all those useless materials and their textures and it worked fine.

In 2.9 it seems materials and their textures are loaded even if the object is shown in wireframe and i guess that this is the base of my problem:
I my blend i got 100 objects linked. Each object have its own material and each material have its own bunch of 8Kx8K textures x2 or x3…

I didn’t make the calculus but i guess this would represent several TERABYTES of system RAM !!!
The thing is that all those objects use the same material and textures and in my mind they all shared the same mat and the same textures ( just like it’s done in unity3D ).

I was wrong !!! ( meaning i misuse blender since now more than 20 years :rofl: )
I rumble blender and devs and the problem is finally between my keyboard and my screen ( wich is often the case ).

So, despite EEVEE has become the 3D view renderer since 2.8, it’s not the source of my problem.
My problem comes from the fact that i got hundreds identical materials that EEVEE has to load and of course it takes lots of time and mem ( as each mat represents several megabytes just for its textures ).

So my question ( and i guess you can easily answer, as i appear to be the only one to have this problem :wink: ) is:

What is the right way of cutting a big project in files while using the same and unique material, so that when i reunite the parts i don’t get hundreds of materials ?

Thanks a bunch and happy blending :slight_smile:

Why do you need them separated?
Why don’t you combine pieces that share materials into one file and then reference from there?

2 Likes

Finally The way i choosed is:

  • creating a .blend carrying all my scenes materials
  • changing each .blend with a wall or tower of the city and giving it a linked material
  • opening the whole scene .blend and see that there is not that 250+ list of materials but only 8 materials all coming from the .blend library

This way my memory and time-for-display problem in 2.8+ should simply disappear.

Happy blending !

EDIT: also changed this topic title to something more explicit :wink: