2.92 was working, now crashes every time I try to render

How do I go about figuring out how to fix this?

Sometimes it will render a few frames and then vanish crash. Other times it says blender stopped working, and other times it vanish crashes before it makes it through as single
frame.

tried it just cuda without optics, still crashes.

It was working fine for weeks.

Just added a sphere and a light to a blank file. Still crashes.

Check the error log, here’s how to find it:

Post it here if you find it, otherwise try to restore factory settings. You can delete Blender’s user data manually (in Windows path is something like C:\Users…\AppData\Roaming\Blender Foundation, just delete the Blender Foundation folder, but note you will lose your addons and they must be reinstalled).

untitled.crash.txt (47.4 KB)

Thanks. Found it. Here is one of the error logs. Would it be helpful to upload another in case for some reason they show something different?

If anyone can tell what went wrong based on looking at the log, please let me know.

You should delete all logs then run Blender again and render something until it crashes then get the latest log. If you upload the wrong log it won’t be of much help.
And if you know how to do it, you can also run Blender from a command line with the “–factory-startup --debug-all” arguments to get more info.


Did you make any graphic card driver update lately?

I saw there was new one, but I didn’t install it yet. I was thinking about installing it to see if it fixed it. also, I am not having render problems in 2.91.

The file I uploaded is from the most recent attempt.

Looks like the renderer can’t write the image file. Check if the output path has enough space. What video card do you have btw? I see some CUDA stuff listed in the log. Beware that CUDA is useless if you have an AMD GPU, it may also mess up existing AMD drivers.

If you are using an HDRI go to your world properties/settings/surface/sampling and change it from Auto to Manual. Map resolution should be 1024 and Max Bounces should be 1024. Try rendering after you have changed the Sampling to Manual. Worked for me a while back.

Thanks, but it didn’t work.

After months of trying to get a 3080, I gave up and bought a 3090 founders edition. So It’s definitely not AMD.

The drive has over 900GB left on it. So it definitely isn’t that. So far the only thing I have been able to do is go back to 2.91 to get it to work.

If it works in 2.91 then it must be a bug in 2.92, you should report it and post the logs there:

not sure about your case,
for my case 2.92, whenever there is an outofcore rendering no matter CUDA or Optix, it crashed to desktop

In 2.91 CUDA is okay, able to render succesfully, but Optix will give me cuda out of memory error. But at least, it does not crash to desktop.

How do I know if it’s an out-of-core render? I haven’t heard that term before.

I tried just loading up an hdri for the background and lighting, a UV sphere, and one area light. It’s still crashed. Yet for weeks everything was working fine even with scenes had a lot going on in it.

i believe yours is a different case than mine.

For mine, i am trying out the adaptive subdivision. I am addicted to crazy displacement map for the last few weeks and did a lot of experiment with it
adjusting dicing rate (adaptive sub-d) in 2.92beta too low will break the render and crash to desktop.
While in 2.91, i will see my gpu shared memory filled up and my system RAM grew to 30GB± and in worst case, system become unresponsive instead of crash, which is expected.

for the out of core, i did it in a crude way,
fire up my task manager, take note at ‘shared GPU memory’ stats just right after the render started.
for my scene, cycles crash when my ‘shared GPU memory’ started going up, in other words, the VRAM onboard is not enough and the scene started to load to system RAM.