2 lamps, ray shadow and smooth problem.

Hello everybody,
I’ve a problem with lighting a simple scene. I’m using blender 2.49b for mac.

I’ve created a cone using the default mesh.
Then i put a lamp on the right side and a lamp just in front of it.
(I mean: there is a lamp between the camara and the object, and a lamp on the right side of the object).

I set the cone to “smooth” in the editing (f9) tab.

when I render this scene, I obtain a very sharp chenge of color on the cone, just in front of it, that makes it very innatural.

If I turn off the ray shadow, the lighting on the cone is ok, but there are no shadows.

If I try to make the shadows softer, in order to avoid the sharp change of color (that is cause by the shadow projected by the lamp on the right) I obtain a very pixeled shadow all over the cone.

Finally if I switch back to a “solid” object, ray shadow works fine.

What can I do to have the same light as when I switch off the ray shadow, without losing the shadows?

I’ve checked normals and they’re ok.
I would not like to make subsurfs because I’ve to use slow computers and I’ve to teach basics to people that has no idea of blender.

Thanks to all.
G.

cone.blend (134 KB)

can you upload file so we can test it

and you could change the type of light set up you have like using some Area ligth with emi light may be to give smoother shadows!

this is the old light set up dilema you have to select the right lamps set up and locate them to get the right look!
but not always easy

happy 2.5

oh thats u ur using some really wrong lamp settings.

  1. set falloff to inverse square in lamp settings.

i also turned a AO & i think ur simple scene looks ok now.
heres the blend:-
http://www.pasteall.org/blend/5320

btw i recommend u to switch to blender 2.5x because it has a faster raytracer & so much more fun.
edit:- oh yeah forgot mentioning i tweaked a lil lighting & material too.

@rickyblender: at the end of my post there is a .blend attachment.

@mohd: yes, thanks. it looks quite better. But still there’s something that doesn’t convince me. I try to explain it (even if my english has some limits :D)

in the blend you upload, there are 3 light. If you look at the cone, there are 3 areas: the left area is “middle dark”. the central area is the lighter. the right area is the darkest.

what looks weird to me is that this change from an area to another are so evident.
By the other hand, looking at the vertical line between the central part and the right part, we can see that there is where the reflection of one of the three light is. That part should reflect the light and the vertical line should be invisible. am I wrong?

If you turn off the shadow in the three lights, that’s how I think the cone should look like. Lights without shadows merge between them and you can’t see a separation between areas of the cone. Doesn’t it look more natural in this way (except for the missing shadows…)

As you already understood I’m not a blender expert. So maybe I’m just wrong about how the shadows should look like.

Finally: I’ve learnt something about blender in the version 2.49. I’ve not downloaded the 2.5 because it seem to be still unstable.
I’ve just downloaded now to have a look and… wow! it looks very nice!

Is blender 2.5 working well or does it give problems? I want to give an intro to blender to my students 'cause I think is quite interesting. but I need a certain stability in order to present it in class.

Thanks to all.
G.

i think it is good enough to begin working with it

nly problems is that not all tools are like in 2.49

so for modelling i still use 2.49
but for rendering and scripting i use only 2.5

it’s becoming more stable but not 100 % yet and lot’s of new features missing but should be added soon i guess and hope

but i did not have any crash in a long time but depens what you do with it !

but get teh latest version at graphical.org
they are upated almost daily so should be stable enough

good luck with 2.5

i used the last file
and remoe the spec an diff on one lamp

how about this

[ATTACH=CONFIG]129489[/ATTACH]

happy 2.5

yeah 2.5x is very stable,almost complete and super cool. u can use it its very usable now.
k i figured out how to solve ur problem.
delete ur cone & add another one but this time set its vertices from 32 to something high like 256 and turn off smooth (i mean shade flat). and ur problem is solved.

its cos with so many polys since the distance b/w 2 consecutive polys is so small it automatically smooths out.
k thats it

and before i forget ur cone is penetrating the floor move it up man.

k bye

you can also add some environemnt light to give better gen light in scene

happy 2.5

@rickyblender i already added AO to his scene & there isnt any environment lighting in blender 2.49 lol

sorry i work now mostly with 2.5
it’s a lot better for rendering and even faster

try it you’ll see

i can upload the 2.5 file if you want too

but as i said you can also remove the diff spec for the lamps that would remove the harsh white reflection on the cone!

happy 2.5

Thanks a lot guys!

I think the “increase vertex number” trick works fine for me.

Correct me if I’m wrong: add many vertices will slow down the rendering process, right?

By another hand:
The solution provided solves my problem. But I still don’t understand why the “smooth” cone does not work so well.
I understand that, with a single light source the shadow is very very sharp (it pass to complete black suddenly).

What I cannot understand is the situation with 2 lights. It seems that it just “sum up” the components of the 2 lights, so it creates the 3 areas I mentioned in a previous post. But that’s is innatural.

It sounds to me that I’m missing something.

Finally: I’ve noticed that if I make my object transparent, the shadow’s still there, with the same intensity. Is that a rendering problem or I forgot to switch on some option?

Bye.
G.

p.s. Thank you very much! you’re advices are very helpful and I really appreciate your help!

First of all regarding smoothing issue i wud say that pointed object always cause a problem if used with smooth. Dont know why that happens but it happens so u fix it. :slight_smile:

  1. Regarding ur ques. Bout lamps adding up to give u like 3 lamps i wud suggest u to go to blender.org and chk out the lightning tuts. They may arise due to wrong setup of light.

Lastly regarding shadows of added up intensity first make sure u checked transshadow btn. U shud also not forget that blender internal is a non-physical based render.
So there maybe some physical flaws but all that matters at the end of day is u get what u want instead of how u got it. :wink: