2-point tracking: Armature "Stretch To" constraint w/o Volume?

I’ve got some pretty good track points and am trying to overlay a video clip with my own logo using the 2-point tracking method described here (and many other places): https://www.youtube.com/watch?v=oBBv4Plk0cw

The armature has the bottom right track as a parent and has the “stretch to” contraint to the track on the top left. My logo then has the armature as a parent.


This setup works awesome for most of the scene. However, in the very beginning of the scene, the tracks scale down. As my armature scales down, it distorts my image rather than simply scaling it down. I have the Stretch To volume turned to None, so I don’t understand why the logo stretches in the X axis…


How can I get my image to simply scale with the armature, not distort/skew?

Firstly you are not scaling the ARMATURE, you are scaling a BONE within it, by using the Stretch To constraint. This may be why no-one has answered you yet…

However, and as you didn’t post the blend file I have to guess somewhat - note that for future and include a blend file showing the issues, that also increases your chances of a meaningful response.

So If I guess correctly, you have a bone with a Stretch To that is tracking around a circle? So the bone will stretch/shrink since it is not at the centre of the circle. You should have parented the logo to the bone with a “Bone” parent, yes? The bone is stretching therefore any object parented to it will also stretch - you don’t want this, so the solution is:

Add another bone where you want your logo to be, parent this to the “Stretch” bone and make sure “Inherit Scale” is NOT checked - then this new bone will not stretch as the “Stretch” bone does. Then Bone parent you Logo to the new bone (Select Logo, SHIFT+Select new bone, key CTRL+P => “Bone”. Then animate the Stretch bone - all should work as intended. Bones, when parented to another bone in the armature can inherit Location, Rotation and Scale and can be connected or not - just check the options you want to use…

Cheers, Clock.

I am also looking for a solution. What I believe he’s trying to say is the VOLUME is changing and he doesn’t want volume to be retained. He wants the SCALE to change only. So you’re solution won’t work. But I think with the “Stretch To” constraint the volume might be an inherent feature. Too bad we can’t switch it off. Thank you

Just leave the Stretch To constraint default settings as they are, turn on the Volume Min and set it to 0.1, Volume Max leave as default 1.0, voila, you get no volume detention nor distortion when stretching bones.

Thank you!.. I had previously put these at 0 but to no effect… I will try as you say!