2 x GTX 1080 TI but blender says => No opencl devices, someone help!

So i’m using blender for it’s compositing filter glare. I find it really nice.

I see it has opencl support. It does nothing when i enable or disable. When i look into options it shows cuda devices but no open cl devices. I have both 2.7 latest en 2.8.

I import openexr file =>add gamma>filter glare >output. When i render animation, its just using my cpu not gpu.

I don’t know what to do.

Opencl is for radeon. cuda is for nvidia.

but nvidea supports open cl1.2?

I know for radeon or nvidia, the opencl drivers must be installed.

https://www.quora.com/How-do-I-install-OpenCL-on-a-Gforce-Nvidia-Graphic-card

Why not use the cuda cores?

How do i use it? I only see open cl.

I don’t mean for cycles, i mean compositor, where u can open openexr sequence, then add filters, then render it out. Those nodes have “opencl check boxes” no cuda.

Now ifi enable or disable it still uses cpu and it’s slow.

ps: i checked, drivers is installed and it supports opencl 1.2

I found out what could be your problem.
https://docs.blender.org/manual/en/latest/render/cycles/gpu_rendering.html

It says here in the manual, it only supports opencl 2.0 and later.

having said this, it could be possible to get opencl 2.0 support with your nvidia cards. You will have to search and find how.

thanks for your help! I willdo research now. I’m about to buy those new rtx cards, hopefully they support it.

Edit: But it seems it for cycles engine. Hmm really confusing.

To use Blender with OpenCL on NVIDIA cards you have to start it from a terminal with:

blender.exe --debug-value=256

Don’t expect miracles. NVIDIA purposely crippes OpenCL performance.

Edit: Oh and welcome to BA. :slight_smile:

1 Like

Thanks for the welcome and the help!

I tried it, i don’t see any differnce, should i enable something in the settings? I enabled cuda as for cycles but i don’t see anything for open CL.

On 2.8 i did see open cl settings (where it says no device)

I tried the code with 2.8 and it did not open.
2.7 did open but i did not see gpu working.

thanks!

Try switching to Cycles and enable split kernel. Then you can specify OpenCl devices.

Btw. I had a typo up there. It’s just:

blender.exe --debug-value 256

I can’t promise that it will work in comp. I will check that tomorrow. It’s late here.

You might want to have a look at the Blender OpenCL Wiki page also.

1 Like