2012 MAC Lattice tool poor performance ie: SBBOD (Spinning Beach Ball Of Death)

I have a 2012 5.1 Mac Pro Tower 3.2 Ghz Quad Core, OS X 10.8.4, an AMD Radeon 7950 3 gig graphics card, 32 gigs of OWC ram with an OWC Solid State start up disk with 150 gbs of free space. No other applications running other than Blender 2.69 64 Bit.
I am getting the SBBOD (Spinning Beach Ball of Death). Currently with the Lattice tool in Blender. I am working on the 3rd Alarm Clock tutorial on YouTube. While the narrator is doing everything his work flows in real time and I am constantly having to stop the tut while my MAC catches up. I am new to Blender and I think the Lattice tool is irrelevant to the performance issue. I am not sure what part of my MAC or 2.69 settings would cause the Lattice to stall on rotation and switching from Edit to Object Mode and probably everything else? The MAC Activity Monitor seems to indicate everything is fine. I would like to do a benchmark test on GeekBench but I don’t know if its worth the $15 for the 64 bit one? Any ideas would be greatly appreciated.
Please no PC MAC bashers.

No offence from PC user’s side - Radeon, however power, is not on par with nvidia cards concerning Cycles renders. Read technical help forum posts about Radeon cards issues. This might be the cause of SBBOD for you.
To check if it is switch to CPU render mode.
While i do not get why instructor is so generously using vertices and setting subsurf 3 for the view, this alone should not bring your MAC to the knees.

That’s a nice system! eppo is right that Radeon cards have trouble with Cycles (shader compile times are insane), but that doesn’t affect regular modeling. Agree to switch to CPU for Cycles rendering. Mac OS 10.8.5 drivers for the Radeon 7950 only include a couple of bug fixes, while 10.9 has a ton of work and optimizations for this card and its cousins in the new cylindrical Mac Pro. Upgrade to that (it’s free) when you’re ready.

Thanks eppo for answering. I am on MacRumors and was just tired of PCers bashing MACs. Its hardly the issue when I already own one… lol.
You are really nice. I don’t know how to switch to CPU render mode. Please explain. And subsurf 3 is that a Blender pref, please explain.

Thanks a lot significant-bit. I will try Maverick (and its free? I like the price) I will try my Radeon again with that. I have another Graphic Cards I can try an Nvidia Gigabyte GTX 285 2 GB from an older machine. Do you think that will work in my new MAC if Maverick doesn’t help? I have looked at all the MAC system and Blender preferences but I don’t get how to switch to CPU render mode?
Oh, eppo BTW I didn’t get it when you said the instructor, you were curious enough to watch the YT video. That is sincerely incredible. What a guy… I will search forums for Radeon issues thanks.

Blender needs certain so called nvidia CUDA Compute Capability number - GTX 280 is CC 1.3 which would not fit anymore.

NVidia CUDA is supported for GPU rendering with NVidia graphics cards. We support graphics cards starting from GTX 4xx (computing capability 2.0). Computing capability 1.x cards are no longer supported, but you may still be able to compile experimental builds with a limited feature set (see below).

from http://wiki.blender.org/index.php/Doc:2.6/Manual/Render/Cycles/GPU_Rendering

If i think again, if you had not downloaded special build or something you should have just CPU rendering available:

Cycles has two GPU rendering modes: through CUDA, which is the preferred method for NVidia graphics cards; and OpenCL, which is intended to support rendering on AMD/ATI graphics cards. The implementation of OpenCL is only in an experimental stage and disabled in official builds.

  • from Stackexchange pages.

Can you model freely and are stuck on rendering?

For the subsurf modifier - higher you set it’s values more job your MAC has to do. In general level 2 is considered normal: you could use level 1 for the viewport and level 3 for the fine rendering. Say, circle made of 8 to 12 verts extruded and subsurf lvl 3 would make fine surface for the cylindrical details on that watch. Narrator (tutor, author, whatever this is called) basically used default sphere/circle consisting of 32 vertices. This plus lvl 3 subsurf makes quite a bit of the job to calculate lattice influence.

Just note that all the talk of changing to cpu and CUDA will have zero effect on the issues you were describing in your original post. These refer to rendering your final scene, nothing to do with modelling or doing anything in the 3D viewport.

You current computer spec is more than sufficient to run blender. Try using the lattice with lowest subdivision modifier settings. See if there are any newer graphic card drivers from the manufacturers site. In the File / User Preferences / System panel you could try turning VBOs on or off and try the various window draw method options.

SubSurf level 3 + a lattice is just asking for slowdown, even on the fastest PCs. Especially if you have the lattice modifier AFTER the subsurf modifier in the stack. Try putting the lattice higher in the stack, and working with a lower subsurface level. It’s rarely necessary to work at full mesh render resolution.

Richard Marklew and m9105826 (I hope I spelled that right?) Thanks so much for the info. I may try a different card as in an Nvidia and see if everything on my computer plays better together? I am also having an issue with another favorite program of mine Toon Boom Harmony with their morphing tool being sluggish. The new card route may help this also? I can’t update to the Maverick system as Toon Boom Harmony has warned against upgrading. They haven’t worked out some issues.

I really appreciate everyones help so far, what a wonderful Blender community, Shayla

(((UPDATE))) Looks important doesn’t it… lol.

Yesterday I decided to try the cheaper route and download Mavericks to see if the drivers with 10.9 played better with my 7970 Radeon Graphics Card. I was not able to boot Mavericks past the Grey Screen. I zapped my PRAM on reboot and booted to my second OS 10.8 25 GB partition on my 250 GB Solid State Start Up Disk. I am wondering now if part of the original problem with Blender 2.69 above and the current problem with Mavericks might be the Radeon 7970 isn’t the official MAC version of the card (at the time there wasn’t one). Per MACRumors it did work with the 10.8.4 drivers. Although maybe not too well? I did some research and Mavericks not booting could be an incompatible graphics card and driver? Therefore in spite of my small budget, today I bought a new EVGA GTX 770 4GB MAC Editions graphic card. I think I will wait a few days for the GTX card to arrive and see if Mavericks boots with the GTX MAC card and the Mavericks drivers? This I hope will also take care of the Blender 2.69 performance issues listed above. Blender 2.69 and my previous Blender file both are on the larger grey screen partition and open and seem to work as well as before. I haven’t been able to find if I need to use the larger partition for a Blender scratch disk? Or if Blender even requires one?
Anyones opinions on these new revelations are cheerfully sought and regarded as a helpful opinion.