20k samples & still noisy... is that normal on heavier models?

This is a 600mb model with quite some detail (thousands of objects), some basic materials slapped on there, 600 strength emissives (because they were very weak otherwise), and a very dark HDRI background.

Before you say denoise, I get really weird artifacts with both OptiX and OpenImage in 3.0:

(It looks like a jpeg, but it’s straight from the compositing viewer node in Blender!)

Even after 20k samples, there’s a lot of noise:

Also, the above is exterior with emissives as I said, but I noticed how I need to crank the interior spotlights up to crazy 300W and it’s still too dark…

Is there some “complex scene rendering 101” video I can watch because I think I’m missing something basic here.

Out of the box, Cycles is perhaps setup for something different, simpler and smaller stuff with skylights?

Can you share file?

It’s a file from work, so I can’t.

20k seems very high. Very difficult to analyze with nothing more than these images, though I doubt Cycles can’t handle your scene. Off the top of my mind:

  • Check exposure under both film and CM tabs.
  • Are you denoising correctly with the denoising data in comp? If you are also make sure denoising is turned off in the Render properties
  • Do you have enough bounces enabled?
  • Is your hardware capable enough?
  • Do you have frosted glass in places?
  • Is the general scale reasonable?
  • at what sample count would you say the result converges? Like at what point does an increase in samples make negligible difference? You could render at 4x the resolution and scale down in post.
1 Like

Thanks for the tips!

Just to be clear, the settings I’ve mention are the only settings I’ve (knowingly) changed. Everything else is straight out of the box. But just in case, is it possible to reset render settings without hosing all other Blender settings?

There is no frosted glass and the scale is 1.0 on everything (on an about 12m long boat model with a few dozen of those emissive surfaces and about a dozen of so of those very strong spotlights).

Disable Caustics and change “Clamping” values (ex. 6 and 3) on the Render tab.

Do you mean direct or indirect clamping?

I also experimented with noise treshold, and on 0.01, some interesting patterns were generated:

image

Also I saw small fireflies appear and disappear at around 10k samples, without the noise changing much… so is that the “convergence” that @claus mentioned?

At 0.0001 noise treshold, this was the result after 20k samples (didn’t see much change from 15k and up):

image

But ok, part of why I’m doing this is because we used to render this boat in Keyshot a few years ago and we left that sucker running overnight on a pretty beefy Xeon, so it’s still good that I can get this far after only 10 minutes on a 3090, but I’m just surprised at everyone getting away with just 2-4k samples, that’s all.

Are the lights encased in actual glass? Because that can cause cycles to have a hard time sampling them, leading to noise.

If this is the case, you might want to remove the glass, or if the glass is important, use the light path node in the material to make the glass transparent to shadow rays.

Yes, Direct and Indirect Clamping.

Try:

Direct = 6
Indirect = 3

No, and it’s actually not an as heavy model as I initially led on, because I didn’t import the original Keyshot model but rather a VR optimized version with only 1 mil polygons and around 1k objects.

image

Also, this is straight from the render workspace, so kinda interesting that the left deck light there looks like it has glare even though Cycles is only supposed to do that in compositing…

So, with those settings, I think the noise pretty much went away at around 10k, but the same view as in my previous post now looks like this:

image

(I think it’s now also taking ages to go above 10k samples for the poor thing…)

This is normal, because high values clamped. You can change Exposure value in Render tab.

Disable the noise threshold and see if it improves the render.

In this case, the noise might just be caused by the number of lights (especially mesh lights would be a problem), so that would be a limitation of cycles in its current state. I would try rendering with just one spotlight, to see if the problem persists.

An other theory I might have, are the boat’s main materials all metallic? Because that could also cause this kind of problem.

Yeah, wow what a difference… 600 strength emissive material at 20k samples above vs 0.5w point lights at 5k samples below:

image

What the heck!

We lit basically everything with emissive materials in Keyshot, so ok, that was a big oof! :sweat_smile:

PS. Materials are not metallic, but I am experimenting with the clear coat.

The only post with a noise treshold enabled is this one.

It is hard to say then. We need to see the render panel settings, the light settings, your shader setups, Hdri usage etc. How many bounces are you using in the scene?

Another thing to check is scale - it should be realistic - which can get messed up with a lot of imports (really big or really small - but I’m betting it’s big).

Mesh lights (emissive materials) generate a lot of noise - as you have seen, sometimes it’s better to shut off the actual emission and switch to point lights to simulate the emitted light.

1 Like

As I said in another reply, the settings I mention are the only things I’ve changed. Everything else as is out of the box. I put an HDRI as the background (but it’s dark) and the shaders are just the Principled BSDF that came with the import with some roughness/metallic/clearcoat adjustments.

I also said in another reply that the scale is correct for everything.

But either way, attempting to light a scene using mostly emissive surfaces seems to have been the major culprit. Eevee can’t do this (yet) and apparently even Cycles-X is crap at it. :confused:

I’ve accepted that answer as the solution now.

1 Like

We still do not know how many bounces you set in the scene. The default bounces won’t be enough to light the scene and increasing the samples might not be the solution you were looking for.

Please bear in mind that people are trying to be helpful here, and expecting everyone to read everything in a longish thread is not realistic (everyone is busy right), so people try to answer you based on what they can grasp from glancing over and reading some of the information.