281a and 282 can not run subdivision surface modifier on the object

Subdtest279OK-.blend (574.2 KB)
So this object - 2.79 will run the subdivision surface modifier on this object but when I bring it into 2.81a or 2.82 it hangs It freezes up.
I have a 1070 nivida card and windows 10
so I saved it with 2.79 and I made this object with 2.79 I have not tired to re createt the object in 2.82 just thought of that just now.

sameobjectmadewith282.blend (637.8 KB)
so here is the same object but i made it with 282 I run the subdivision surface on it and it does not do what is expected like in 2.79 it totally distorts the object until I put CTRL R loops on it

One time I copied and pasted this object in 281a and it did what its doing now - nothing. So its my hardware being not compatible in some way with 2.8 But definatly this object when I open it with 2.79 and then copy in 2.81a or 2.82 it hangs and I have to end the program it goes into the " not responding"


so I am running these addons in both versions 281a and 282 and maybe its one of these.


So I am on a different machine now. I removed the addons.
Is Subdivision surface different in 282 ? I need to read the update docs I guess. But when I run sub d on this object with 2.82 if looks like it puts in supporting loops automaticly. ? I will have to try again on the other computer and see if its the addons that are causing it to freeze up. So many things to know !
The first image shows how it looks when I add the sub d in 282 I guess its doing it.

DiffernetMachineNoaddonsh282.blend (613.7 KB)
so this is what 2.82 sub d does to a cube
I am not sure if there is a bug in 2.82 with sub d and it does not like this cylinder object. Its a


above is a close up of this object. its like a pipe not a solid cylinder. It has thickness

This is from my workstation


So its showing side by side what sub div surf modifier does here to this object.
I do not know if this is how 282 is supposed to work ?
Anyway it must have been one of the addons that made blender freeze up.

To clarify the top one is what 2.82 does to this mesh cut pipe and the bottom one is what 2.79 does to it. Sub surf has changed ? So I guess my question is is something wrong with 282 my settings or ?
But since it does the same thing on both my systems I know its 282 treating this obejct different with subdiv surf modifier.
When each new version of blender comes out I should read what they have changed. I guess blender website would be the best place to read up on what they did to new versions.
in case the image order is wrong 2.79 is the one that distorts the shape. All sub d does in 282 is add a few loops.