2nd question regarding transparency


(Xtra) #1

Hi all!

Is it possible to render an object with transparency background, so when I save this image as a targa file and open it with Gimp, I have no colored background?

Thanks & regards,
Xtra


(mthoenes) #2

Press the RGBA (RGB Alpha) setting in Blender and save as Targa… Open in Gimp and you will have transparent background.


(Xtra) #3

That doesn’t work. When I press the RGBA button I get a black background with no alpha informations. Curious …


(theeth) #4

Select Premul or Key instead of Sky in the Display buttons (F10).

Martin


(Xtra) #5

Thanks folks, but it still doesn’t work. I get nothing else than a black background. I tried it with a plane in the background with an alpha value of 0.0 and I tried it without.

Regards,
Xtra


(theeth) #6

the only place that will be transparent is where the world will show through.

Martin


(Xtra) #7

Hi Martin,

I’m not sure whether I understand you correctly. The point is, that I’ve no ‘world’. There’s only one object, and I need a tranparent background for this object for processing with Gimp.

Actually I would render this object with a fully saturated background color (blue) and I would create a mask in Gimp to isolate this object, but in this special case this workaround is impossible.

This is exactly what I want to do:

  • I render my object with Blender and save it with a transp. backgrnd.
  • I want to load an image with Gimp, add a 2nd transparent layer, bring it to the top and copy/paste my rendered image into this layer so that I can see the the rendering in foreground and the prior loaded image in the background.

Mission impossible?

Regards,
Xtra


(Alltaken) #8

it is gimps problem.
as it reads files only as rbg and ignores the alpha channel.

bummer (i have no problem with ulead photo express reading the alpha layer)


(theeth) #9

actually, it’s a problem with Blender’s RGBA output that makes it incompatible with GIMP. As far as I understood, Blender outputs the RGB channel in 32 bits but the alpha channel in 8 bits (or something like this, anyway). The point is, GIMP cannot recognize the alpha layer from the targa. What you could do, however is to render in PNG with an alpha layer (only if you use Blender 2.25).

Martin


(mthoenes) #10

Interesting…
I rendered an image in Blender and saved with settings Sky, RGBA, Targa,
Opened the file in Gimp and got a transparent background just as I expected. Gimp did not have an alpha channel in the channels window though.
(Gimp for Windows).