3 Problems - Animation - Fire/Smoke - Physics Tab

My System . . .

Asus ROG 15.6" Full HD Gaming Notebook Computer, Intel Core i7-6700HQ 2.6GHz, 16GB RAM, 1TB HDD + 128GB SSD, NIVIDIA GTX 960M 4GB, Windows 10

I made this short animation to be a quick intro to a highlight video of a wrestling tournament that I photographed. I have finished it, but the I encountered a few problems during the rendering process (cycles render under the GPU using blender 2.77).

Problem 1 (Animation) . . .

I have 2 words: Torneo Lucha Spartacus. I have the animation key framed to where none of the words show. Then after 1 second, Torneo shows; after 2 seconds, Lucha shows; after 3 seconds, Spartacus shows. Then, right before the helmet explodes, all of the text is key framed to disappear. During playback all is fine. However, during the render, all the words show up from frame one and stays there until the end. Why is it working ok in the playback, but in the rendered animations it is showing up from frame one and not disappearing on frame 120?

Problem 2 (Fire/Smoke) . . .

The helmet has 2 quick effects (quick explode and quick smoke in which I changed to smoke + fire). I made several setting adjustments and baked the animation. During playback, everything seems to be working just fine. However, after rendering the animation, the smoke and fire does not show up in the final animation. I have done research and read several possible solutions, but still unsuccessful. What could be wrong here?

Problem 3 (Physics Tab) . . .

After I baked the animation, I noticed that all settings under the physics tab are greyed out. Now, I can make any additional changes. Why did it do this and how can I change it so I can make additional changes?

I will continue to research possible solutions while I await feedback. Thank you for your time and help. I have uploaded the file to Paste All.

Blend File . . .


Have a great day!

I partially solved problem 2. I turned off the restrict viewpoint selection and restrict rendering options on the smoke domain in the outliner. Now, I can actually see the helmet exploding in the render. However, I still can not see any smoke and fire in the render even though it shows up in the scene.

Re: problem 1: On the text you need to animate the render visibility (Camera icon in the outliner). Currently you have animated only the viewport visibility (Eye icon).

Hello CD38. Thank you for your response. I understand about animating the icons. However, I am a bit confused about animating the camera icon in the outliner. I don’t understand how animating that will fix my text problem. The only animation I have on the camera at the moment is the slow zoom movement. I am having trouble in seeing how animate the render visibility on the camera will make the text do what it is supposed to do. I hope I worded that correctly. I will mess around with it and see what happens, but any additional info would be great. Thanks again for the tip.

Each object in the outliner has a camera icon. Its state determines the visibility of that object in the render. It has nothing to do with animating the viewport/render camera. Just try it: turn off the camera icon for one of the text objects and you’ll see it doesn’t show in the render.

Ah, that is much clearer. For future reference, would it be better just to animate the camera icon or do I need to animate both the eye and camera icons? Thanks again.

Problem 1 solved.

Now, onto figure out what is wrong with my smoke and fire.