3D-Coat Applink for Blender 2.8

I think that this workflow is a little too hacky to make a script for this. For me the best thing could be that we could change layer type into -> Vertex color in 3d-coat and then export multiply vertex color maps with one fbx file. Then It would be easy to add this feature into 3d-coat applink.

Please let me know where the URL for the addon is. Thank you. I use 3dcoat for some things texturing. (normal mapping painting)

it comes with blender :slight_smile:

Awesome! so the addon works now? I´ve been using it since 2.79.

Yes. All the main features should work now. I don’t have so much time at the moment because I went back to school but if there is some bugs/feature request please write them down here and I take a look when I have time.

Now if you want to take a mesh from blender into 3d-coat to do some manually retopo, that should be more fluent workflow what it used to be in the latest applink version.

1 Like

Psssssst… some crazy fool is selling his 3DCoat 4.x Pro license… get this… for only one hundred and sixty clams!.. over on this thread

I upgraded to the latest stable 3D Coat 4.9.17 and Blender 2.81a stable release. The retopo workflow is still perfect and suuuupersmooth :sunglasses:, but exporting “Mesh As Voxel Object” from Blender for a little Sculpt-magic in 3DCoat results in a tiny mesh when bringing the results back to Blender via File/BringVoxelsBackToApp . :flushed:

Make sure that you have pressed “Reset Axis” and “Reset Scale” before applying mesh into 3d-coat.

The scale is still off by 100fold (so reimported mesh in Blender is 0.01 times scale of original), but it did solve the issue of having a misplaced origin, which it had with my previous try. :slight_smile:

Ok. I will do some tests…

1 Like

Hi, newb here. I got the 3D-Coat applink working for Blender 2.8. Tried in 2.82, got this:

just want to make sure it’s a known version issue, or find out what I might be missing if not. THanks!

I made some improments. Util now applink worked that it created as many textures you had materials. The con of this workflow is that it creates many textures.

Now there is a better way. Now you have option to create textures using your uvsets. This way less textures are created and you can pack many objects into one uv area if you want.

Sorry guys it took this long time code this :frowning:

I will update this into blender addons and it should be included starting in tomorrows build.

2 Likes

Here is the latest version. There has been complete redesign in code so there might be some bugs but’s lets fix the one by one together :slight_smile:

io_coat3D.zip (53.7 KB)

1 Like

If someone has had issues to make this work, please download latest 4.9.36 and also download this folder into your addons folder.

io_coat3D.zip (18.9 KB)

1 Like

This shows the Update to the Applink, which was rewritten, and is more streamlined (along with needed fixes) than previous versions. Make sure to use 3DCoat build 4.9.37 or newer, as it contains the new Applink code. The video uses Blender 2.82, but should work with newer builds, too.

1 Like

I can’t get an object from Blender to 3D Coat. I can get an object from 3D Coat to Blender. I’m thinking my configuration files are not correct. I’m using Blender 2.82 and 3D Coat 4.9.37. Can you post where/how Blender looks for the 3D Coat exchange location? I see there is written an “Exchange_folder.txt” when going from 3D Coat to Blender, but is this use for Blender to 3D Coat? Also, I have an “ApplinkObjects” folder inside the “3DC2Blender” folder with a file named “3DC000.fbx” is this the file 3D Coat is suppose to recognize to import a new object? If you can give a little guidence, I’m sure I figure how to fix the configuration. Thanks.

Forgot to mention I’m using win10, and I tried applink version 5.0 that came with blender 2.82, and I also tried downloading your 5.0 zip above in the post 3 posts above mine.

Hi! Do you have OS and 3d-coat app in same drive? I get some reports that are saying if windows and 3d-coat in separate drive, then applink has some issues.

Same drive…default locations.

So when I create a cube in blender, have it selected and press the only button on the applink “Send”, I then move over to 3D Coat and nothing happens. I’m looking through your python code in VS Code to try and find where the file gets written from Blender to see if it is updating upon pressing “Send”. I assume 3D Coat is looking for that file or something else is invoking 3D Coat to look for a new import…but cannot find that info yet.

When you press send in blender it should create impot.txt file into \Documents\AppLinks\3D-Coat\Exchange folder. Can you see that it’s creating this file?

I just saw that in your code…I can confirm that this file does not get created when I press “Send” in Blender.