3D-Coat as a companion to Blender

I had worked with 3D Coat before, so to me it was a matter of refreshing my memory, and learn some new things that have changed since 4.x.

My best advice is to take a few days to view videos from the channels mentioned in the initial post, and trying things you’ve learned in 3DC right away, so they’ll better stick to your muscle memory.

Set Edit menu ➔ Preferences ➔ Viewport tab ➔ Fixed Scene Scale to 100. That should sync dimensions between Blender and 3DC.

1 Like

Set Edit menu ➔ Preferences ➔ Viewport tab ➔ Fixed Scene Scale to 100. That should sync dimensions between Blender and 3DC.

<3<3<3 :slight_smile:
Thank you very much for this tip, I completely missed that!

As for the rest, I will do. I suspect, as usual, the first weeks are the hardest, it’s normal.

1 Like

Definitely. Patience is key, and learning some basic principles first, such as the difference between Voxel layers and Surface layers, and the brushes that are to be used in each mode.

In essence, Voxel layers are comparable with ZBrush Dynamesh (revoxelizing and reprojecting to build volume with evenly distributed faces), and Surface layers are like dynamically working with meshes in ZBrush Sculptris Pro or Blender Dyntopo (adding polygon detail where you brush).

1 Like

Sorry I got pulled away on a call earlier. Thanks to to Metin for getting back.


Added some 3D Coat tutorial video channels, 3DC forum links and a tip to the initial post.


In the relatively short-lived period I previously used 3D Coat 4.x (years ago), I created this zombie head, based on concept art by Serge Birault. :slightly_smiling_face:


Another +1 for 3D Coat: the developers are really involved, including actively checking out user reports. I encountered a bug causing the FFD cage to be displaced. Reported it over at the 3D Coat forum, and a new version with the fix was released within a few days.


Update: added 3DC-related Twitter profiles to the initial post.

Can somebody help me with the installation of io_simple 3D Coat from https://github.com/mifth/mifthtools/tree/master/blender/addons/2.8/io_simple_3dcoat ?

I’ve installed the two .py files, (they don’t go into their own directory, apparently, but they reside in the /addons/ one); when I activate the addon, I get the N side panel for it, but no option to select a custom directory for the exchange between the two programs. Is that correct? Do I have to type it manually in the .py file?


That does not have to be like that. There are several ways to do that, but the easiest might be to put the two files in a zip and place them inside that zipfile in a folder eg “simple3dcoat”. If you install the addon from that zip the folder will be created. ( as a rule of thumb dont use special characters for the folders name)

Once you have it activated you can define a swap folder in the preferences of blender, in exact the same place where you activated the addon. (listed below the addon entry)

1 Like

Thanks, but the zipfile thing was the first I tried, still the .py were still dumped in the root.
Also, there is no option in the addon panel under preferences.

The addon prefs also states that the plugin resides in the /io_coat3D/ directory, but that directory is not anywhere in the addon directory when I browse from Windows

I’m at loss. Unless the new files are not in fact installed during the process, and instead the embedded addon takes priority?

Please note that when I search through the addons search feature for it, this one is the only one that appears.

Thats not the right one at all. Thats the org that has been forked by mifth. And the folder setup panel isnt there because its still deactivated

1 Like

can you tell me the name the new one should have once installed?



The console says that the addon is installed, (I used a zip again, but with a directory of the same name now inside it, and it’s correctly placed in the addon directory).

But it’s not anywhere in the prefs addons panel still.
If you are aware of some other thing that could interfere, I’m all ears. Thanks.

I think your problem is that you have to clean it up first. It interferes with older files or even the one that comes shipped with blender. Try this:

  • So uninstall it again
  • Then navigate to the addon installation folder.
  • Check that there really is none of these two files in the addons maindirectory left and also no subfolder
  • Then take your prepared zip containing a folder and inside that folder the two py files
  • Install from that again.
  • Activate it ( it should list the one with version 0.4.0)
  • Set the folder
  • Save preferences
1 Like

Awesome thread, I’m currently interested in it’s PBR texture painting tools in comparison to Painter. 3DCoat and Blender could be the best pairing in a while, that is until Blender catches up.

1 Like

your explanation is very clear, thank you, and I concour that it should work.
but still doesn’t.
It’s like the files are copied correctly, but not registered in Blender.
I give up for today :confused:


Ok. Good luck!

A last simple try might be to remove the shipped one testwise from the installations folder: YOURINSTALLFOLDER\3.1\scripts\addons\io_coat3D