3D Cursor "Geometry" Orientation bug?

Trying to understand whether it is a bug or not.
I want to make the 3D cursor respect the normal of the polygon.

For example, a simple cube was taken.
Snap and 3D Cursor Orientation Settings:

Then I turned and moved the object in edit mode so that the center remained at the coordinates 0 0 0

And the finally I use 3D cursor

As you can see the 3D cursor does not match the surface normal.

It does match the normal, but only the normal; the other two axes it calculates arbitrarily. That’s how ‘Align Rotation to Target’ in snapping works, unfortunately, and it’s not specific to 3D cursor.

Ok, let’s turn off ‘Align Rotation to Target’.
It’s seems no different


May be it’s 3D Cursor limitation?

For the Edge Snap I use ‘Align Rotation to Target’ and it need only one axis to calculate, no problem with that.

Found this


I think it’s a limitation of current 3D Cursor in Blender 2.81

I’m not sure what ‘seems no different’ to you. In 2.81, with ‘Align Rotation to Target’ enabled, orientation of cursor aligns to surface normal, just like any other object snapped that way would.

I don’t know how to explain more clearly, but I’ll try.
‘Align Rotation to Target’ align to normal but for one axis, we both agree with this.

Next let’s turn it off, and enable 3D Cursor Orientation “Geometry”
then click on some polygon. You’ll see that no different.
According to the logic of things it should line up along the normal of the polygon and calculate three axes but it calculate only ̶o̶n̶e̶ two.

That’s why I want to understand whether this is a bug or not.

P.S. To be more precise, it calculates two axes at the polygon, and the third is calculated arbitrarily.

That’s not a bug, that’s how this alignment works. Has worked for ages, even before cursor orientation was implemented. Indeed, it could be worth a proposal to improve it so that full orientation is honored, and not just normal direction.

1 Like