3D cursor not showing / Problem with appending

First of all, my 3D cursor isn’t showing. I googled and tried a lot of solutions like shift + c. But none of them work. The thing is gone. Also I don’t see the median point of an object anymore, so the little orange dot.

The second problem, when I try to append an object it al works fine. I press a grab it, rotate it, no problem. But when I append another object. I can’t select it with a, because it also selects the previous object. And when I select it with B, I can’t grab it. It’s really annoying, because I can’t finish my work.

Reset the 3d cursor back to the grid origin with ‘Shift+S / Cursor to Center’

Set the object origin using the Origin options in the toolshelf in object mode

If you add a new object in OBJECT mode it will be its own object
If you add a new object in EDIT mode you add the new mesh to the currently edited object

I wish that was the solution, because all the things you said I already tried. To be sure I tried it again at the moment, but it still doesn’t work.

I’m sorry, but I already tried all of your solutions for both problems. But neither of them works.

Supply your blend file for review. Describe precisely what you want to do

What things have you changed from the original settings
Is your scene very very very large or very very very small ?

Pooldeck5.blend (6.4 MB)

I really don’t know what I’ve changed. I just want to import objects and move them seperatly.

Turn off ‘Only Render’ display. That prevents things that you don’t see when you render (3d cursor, object origins, emptys etc) showing in the viewport


1 Like

Aaaaaaaaawesome! It was really a pain in the ass. Thanks mate!

This case just happened to me nowadays ( 21/feb/2021, Blender 2.9) and solved clicking the tick box inside “overlay” menu (shootscreen)screen shot