3D Cursor placement problem

I’m building a boat and setting up a rudder. I need to assign it’s center of rotation correctly.

In versions of Blender previous to 2.70, I’d press Shift-S and choose Cursor to Center. Then in the Right view, I’d click my LMB when the cursor was over the point that I want my rudder to rotate about. All would work well. Because I had done the step of Cursor to Center, the X coordinate was 0, and in the Right view, I was setting the Y and Z coordinates.

However, in 2.7, I did Cursor to Center and then clicked the LMB where I wanted the 3D cursor to be in Y and Z, and Blender moved the X coordinate away from zero to the edge of the boat’s hull.

What control has changed? What can I do so that I can set the X coordinate with Cursor to Center and then not have it changed by the proximity of an object in the Right view?

Thanks.

Check in User Preferences / Interface and disable ‘Cursor Depth’

Thanks. I figured there was something in the User Preferences, but I didn’t know what.