3D Cursor snaping on surface by moving with holding (Right)-Mouse-Button

Hello,

I’m not sure how to setup blender for keeping the 3D Cursor always snapping on mesh surface while moving over it with holding the mouse-button for the 3d cursor.

Keep snapping tool active doesn’t affect the cursor.
And holding CTRL or ALT or SHIFT also doesn’t work for it.

Does someone know a solution?

NIWO

cursor depth in user preferences

Ok, that helped me too figured out that the “Enhanced 3D Cursor”-Addon was outdated. :smiley:
But now, i get this error.


Ok, i solved the problem by copying the Meshes to a new blend file. :wink: