3d navigation problems

I am having a frustrating problem with navigating my 3d scene. When I start a new project in blender I can move around the scene fine - I can zoom in and out and rotate the scene using the middle mouse button. However, I have started constructing some objects in my scene and now suddenly (maybe I accidently enabled some option), the 3d navigation has gone all screwy - rotating the scene with the middle mouse button seems to rotate in the wrong direction and zooming in and out is incredibly slow or just isn’t happening at all.
This may have happened after I used camera fly mode I’m not sure.
Have I accidently invoked an undesirable setting or is this a bug?
Even if I save the project and reload the same thing is happening.
Thanks in advance for any help. I am really enjoying using blender but this is halting my project and it’s very frustrating.

Sorry, I forgot to add which version of Blender.
I’m using Blender 2.48a on Windows Vista 32-bit
A bit more information - the problem I am seeing is as if the centre of rotation for navigating the 3d scene has moved far to the right of the entire scene.

if your viewport-camera is too close/too far away from your model, you cannot zoom in, you would need to move your viewport-camera. just like in real life, where you have a limited zoom.
so you probably need to reset your “center of view” (i am myself not sure how it is called correctly).
in your viewport go to view–>“view all” or view–>“view selected”. that should reset your viewport-camera and move it to a place where you should be able to zoom in/out conveniently.
if your center of rotation is not your model / selection, you might want to set your viewport-behavior to “around selection” and perhaps to “turntable”. if you don’t know how to do that you could watch a small
tutorial that i made. http://www.vimeo.com/2389416

Fantastic! That solved my problems thanks. The video is useful too.
I’m still curious though, selecting view rotation to be “around selection” fixed my problem but I wonder how the view rotation centre got moved in the first place…normally I don’t have to select this option and all I have done is added a few extruded cubes to the scene.
Also is the viewport camera different to the camera in my scene?

Thanks again

Ah I’ve worked out when you press numpad-5 to switch perspective/ortho - the viewport rotation centre changes to the currently selected object. A strange behaviour if you ask me.