3D Tranform Rotate Manipulator Problem

I’m having a little trouble using the 3D transform manipulator to rotate bones. I’ve put a quick video up showing my problem:

http://www.youtube.com/watch?v=LszYP0cF4_A

In this instance I can’t seem to grab the blue handle and even when I lock the others it still doesn’t rotate as it should. Is there something basic I’m overlooking?

Many thanks.

Hmmm…

Well to start what mode is the manipulator in (global, local, nomal, view)? It should be set to normal. It looks like it may be set to local.

If that isn’t it, let me know and I’ll hazard another guess :slight_smile:

Sorry… forgot to mention that! Yes, it’s in normal… I’ve been getting around it with a combination of locking certain axis and, if that doesn’t work… parenting an orth camera to the problem bones. But, as you can imagine, it’s a bit of a pain!

The only other thing I can think of off hand would be that a constraint is causing the problem…

If you create a new bone in the armature - off to the side, with no constraints or parents at all, and rotate it so it is offset 45 degrees in each axis, does it do the same thing?

Would you be able to attach the blend? Or replicate the problem in a new file and attach it?

you’ve got an ik on the foot, i think. the system cannot rotate the thigh and still meet the ik constraint, so it rolls the thigh as much as it can, which isnt much.

lol awesome :slight_smile: That is exactly what I was just thinking. I’m wondering if maybe you’ve got an IK switch that isn’t completely turned off? Like this example, the IK influence is 50%, so the bones can be free rotated, but they will be offset by the IK constraint.

Also, try rotating the bone that is isolated, and see if it behaves properly…

Attachments

rotateProblem.blend (148 KB)

Waaaaiiiit a minute… did you lock the Y axis? Because that will do it every time…

edit: for example if you create a limit rotation constraint, and lock the Y…

Well, the character has IK’s on the feet but the video was taken of the arm which has no constraints… here’s a blend: http://www.albinal.co.uk/ES09_Problem.blend

The view I’ve left it in is of the Upper Right Arm which doesn’t rotate correctly even though the X and the Y are locked. If I unlock them then the RotZ is impossible to grab. ???

Hm. Yeah, well when the X and Y are unlocked in the properties window, it works just fine.

I’m not sure if there is a way to hide the other axes of the manipulator without effecting the behaviour of the bones… I’ve not thought about it, since I would normally use auto-IK or free rotating (double tap r) to position an FK arm chain, and only ever use the manipulator for minor precision tweaks. I suppose such behaviour would be handy though!

Turn your pivot point to either “Active Object” or “Individual Centers” instead of “Bounding Box” to get the rotation to behave correctly … Most likely you hit the “,” pivot hokey by accident and didn’t notice … Definitely something to re-keymap once 2.5 arrives …

Armature bones technically don’t have a bounding box center (just the root/head tip which is the center), but apparently when you lock one or more axes Blender tries to solve the rotation as though it has one, but from the root tip ! (this might be something that was added from BBB since it was then we had the snap to option to the middle of a bone when the entire bone is selected in bone edit mode and well as being able rotate it from the bone’s median point) … Maybe they’ll get rid of that option for bones in the pose context in 2.5 … since it doesn’t make much sense now …

Cool… good to know, but changing the pivot type doesn’t seem to change the resulting rotation when the X and Y are locked. Atleast not for me! I tried them all, it always rotates around the body laterally.

I was assuming this had something to do with the bones being evaluated in quaternion space… that if you lock the axes, it won’t behave like you would expect Euler rotations to, it instead follows Quaternion rules or something? It seems to be rotating around global Z? Yeah… I dunno :slight_smile: That was just my best guess!

but changing the pivot type doesn’t seem to change the resulting rotation when the X and Y are locked. Atleast not for me! I tried them all, it always rotates around the body laterally
That’s because you locked them at 0.0 . If you have initial rotations to the X and Y axes like in Albinal’s file you will get the same odd behavior Albinal is getting with the pivot set to bounding box …

And no this has nothing to do with quaternions . Quaternions are an “under the hood” mathematical evaluation of bone rotations (under the hood until interaction in the IPO), not a real time interaction issue (and conversely gimble lock can sometimes be a real time interactive issue with Eulers though not so much when dealing with curves directly)

… Just to show you what I mean, place your cursor in some arbitrary point in space then hit the “.” key on the keyboard to set the pivot point to the cursor, you will notice 1) the 3D widget jumps to the cursor and 2) if the bone like in Albinal’s file isn’t an attached bone, it will behave in some very odd ways even with some rotations locked … Though this is actually useful in some situations, setting the pivot to the bounding box isn’t .

Thanks for all the help! Really appreciated. It this a bug then or not?!?

I am now on a different PC at work and by unlocking the bones I am able to grab and rotate on all of the axis. However, this doesn’t work on my home PC and is shown in the video where I try to grab the blue handle and the red one is the one that I grab… even though my mouse pointer is nowhere near it. It’s this annoying problem which lead me down the path of locking certain axis in order to move the bone I wanted… which in turn led to this other annoying problem where they don’t rotate correctly.

Anyhow, it’s good to know the main problem I have is with my home PC… If I can fix the “can’t grab the right handle” problem then the other won’t bother me. But where do I start in trying to fix that?

No, I actually had the initial values as the file did when you open it, didn’t change a thing. When I rotate it in any mode the arm rotates as if it is being rotated in global Z. So if I understand, is this because the bounding box is oriented to global space?

Albinal,
I’m not too sure how to deal with the manipulator problem, since I’m not having it. But you could try to rotate from a view angle that is not flush with the desired axis, or change the size of the manipulator in the preferences to help you grab it… don’t really know, sorry.

or change the size of the manipulator in the preferences to help you grab it

Do you know how to do this? I’ve just had a look around but can’t see anything. Many thanks.

Yeah, totally… in the preferences window, under ‘view & controls’ on the top right you can see ‘3D transform widget’. Just change those values to your liking :yes: (Don’t forget to then save your user defaults with ctrl+u, or the changes will be reset!)

Thank you! I hope that’s gonna help! I can’t actually test it now as I’m not at home but I’ll keep my fingers crossed that it does the trick. All the best!