3DCoat <> Blender Applink

This video demonstrates the New 3DCoat Applink Connection plugin for Blender (2.8), which streamlines the process of transferring assets between the two applications.
More specifically, it automatically sets up the materials for the user, so they are ready to start rendering with Blender’s Cycles engine or Evee.

3 Likes

strangely video doesn’t show, so here:

1 Like

cool, where can i get it?

It’s actually built-in/integrated in Blender by default, so there is no real install procedure. Just check the applink in the addon section of the Preferences panel. Whatever updates occur with the applink is included in subsequent Blender builds.

Like Abnranger said, the addon comes with blender 2.8.

Here is a link where you can download the latest 3D-Coat version:

The latest version 4.8.38 does not yet include those changes that makes applink works as video is showing. But when 4.8.39 is released (should be in couple of days) then applink works as expexted.

This looks so great. I can’t wait to try it out. Thanks massively for this Pilgway team.

I’m using 3Dcoat 2021 and there is no “export to menu”. I can’t get the blender app link to work.

I also watched other videos. There is no “Open In Original App” anymore on the menu. Doing File > Export Objects and Textures and selecting Blender Applink is the closest I can find, but then hitting GetBack in Blender doesn’t work. I even tried saving as a fbx over the original file and GetBack didn’t work.

I found the problem. In 3DCoat 2021 it seems some things changed. The main thing is the exchange folder in Blender under Scene > 3D Coat Applink Settings needs to be set to the “Documents\AppLinks\3D-Coat\Exchange” folder.
All step are.

  1. Go into Blender > Edit Preferences > Add ons > search for “3D-coat”. the dash is vital. enable it. Maybe restart Blender if 3Dcoat tab doesn’t pop up.
  2. In Bender go to Properties Panel > Scene > 3D Coat Applink Settings needs to be set to the “Documents\AppLinks\3D-Coat\Exchange” folder. This is vital and the only folder that will work.
  3. Setting Object/Textures folder to any location. This will be where the textures objects are stored when reimporting form 3dcoat
  4. Select something. go to 3dcoat tab in blender. Hit send. Make sure 3dcoat is open before hitting send.
  5. Open 3Dcoat if you didn’t have it open already. 3dcoat should have a pop up.
  6. Make changes wanted in 3dcoat.
  7. Go to File > Open In Original App.
  8. In Blender hit GetBack in the 3D-Coat plugin tab.
1 Like

I can’t seem to get this to work. :frowning: Tried all the fixes like deleting the options.xml in Mydocuments/3D-Coat, and tried setting the exchange folder to what was shown in the last post. Nada.

Is this just a 3Dcoat issue?

The only thing I can see that’s weird is Blender erases the path for the exchange folder after I try and hit send.

Blender 2.93.5
3DCoat 4.9.72

There is a fork, try this please