3DCONNEXION Space Navigator not working in 2.82

I have a 3DConnexion Space Navigator that works well in previous blender versions.

In blender 2.8 (mac), no worky at all. I don’t see an addon as I compare it with 2.18a, so I don’t know what I could copy from the old blender folders to the new one, if there is anything to copy. I suspect there’s a script, and I’m about to start digging for it.

Anyone else using a 3DConnexion Space Navigator successfully in 2.82? Any tips well appreciated.

Found a working solution. There’s a passel of .py scripts inside blender 2.81a, but not in blender 2.82. It looks like similarly named files are there instead, with a different extension: .pyc.

I pasted in the old .py scripts, however, and now my spacenavigator is working again. I didn’t remove the .pyc files yet.

I’m on Linux and it worked fine, only they changed the behavior a little bit, now you’re on 3 axes in orbit mode.

Oops, not all functions are working. The buttons on Space Navigator don’t work. Right one does nothing, I think.

The left one shows an error message about a menu being missing.

The left normally shows the setting for the space navigator and the right one is fixed (i guess) to zoom selection. But on some versions i saw it only working 100% with the a or b revision (2.82a).

Coincidentally, I tried the 2.83 Alpha today (so I could enjoy BlenderGIS).

The Spacenavigator menu buttons still don’t work yet.

I am 100% happy with 2.81a but I have now downloaded the 2.83 alpha. It all works right away. I would advise you to send a bug report.

I like to provide a bug report when I can; I can’t do this any time soon. If it’s happening to someone else, please go ahead and report it.