3Dconnexion SpaceNavigator has limited functions in latest Blender vs

I just updated from Blender 2.76 to 2.79, and my SpaceNavigator didn’t like that:

The device can no longer move up/down or from side to side. Everything else works as expected.

All settings are the same on the SpaceNavigator and in Blender…

1 Like

My SpacePilot works well in 2.79 and even better in 2.8. What are your settings like in Blender?

Thank you very much for your reply!

I have narrowed the problem down to this:

SpaceNavigator does move if I press SHIFT while using the device. So I probably need to change a setting so the device no longer needs SHIFT.

However, if I go to Blender/Preferences/Input/3D View/Move View/NDOF and remove the tick from SHIFT, the device almost stops working, and the only way to make it work again is pressing ‘Restore.’

Here are the settings that work in Blender 2.76.

Just out of interest… Are you talking about using it while in any view, like while editing, or when controlling a camera, or both?

My settings are very near default I think and AFAIK Blender completely ignores settings from the 3dconnexion software.

It might also be worth your while downloading a 2.8 build to test. Changes were made to it recently in regard to these devices which fixed a bug involving almost no movement in walk/fly mode.

I primarily use it for editing, in any view.

Yes, Blender ignores 3Dconnextion’s own box. But the 3D mouse should respond to changes made in Blender’s preferences; however it currently almost freezes when I make any changes.

I can’t update to 2.8 because I’m using Octane Render which needs 2.79…

I only meant testing it in 2.8. It’s hard to work out what’s going on. Did you manually change all the settings in 2.79 and then realised it wasn’t working as expected? It might be worth resetting everything to default in case there was a fundamental change in the way Blender works with these devices somewhere in between 2.6 and now.

Thank you very much again! I tried 2.8 as you suggested, and it worked perfectly!

So, that’s really great!

Like I said I can’t use 2.8 yet, but now I know it’s going to work later on when Octane Render gets its next update.

And yes, I manually changed all the settings in 2.79 – and that was quite a nightmare :slight_smile: so I think I’ll just download new copies of various versions between 2.76 and 2.79 and see what works.

Again, thank you for pointing me in the right direction, much appreciated!

1 Like

Did you download the official release version of 2.79 or the most up-to-date 2.79 version from https://builder.blender.org/download/ ? It might be worth checking that out as it contains stuff that came out since the official 2.79 releases.

Glad you are getting somewhere anyway. You can still model and stuff in 2.8 and append the objects to an older Blender version. The .blend files themselves aren’t backwards compatible.

I’ve downloaded and tried everything back to 2.78b now – but they still didn’t work. :slight_smile:

I looked up your SpacePilot, since it works with 2.79, but unfortunately it’s sold out everywhere…

So, I think I’ll ask in a new thread if there are any new alternatives to SpaceNavigator that work with 2.79b.

I had a SpaceNavigator years ago and barely used it. I sold it on eBay. Recently when I started using Blender again more I hankered after one. My main purpose for it it not to navigate while editing, but to control camera moves to give things a more natural and hand held look.

I didn’t fancy paying for a brand new SpaceNavigator though. I found I could cheaply buy (from eBay again) the really old, original SpacePilot. It’s barely supported by 3dConnexion anymore, but there are drivers and Blender doesn’t care how old it is :slight_smile:

I use it a lot for planning camera trips, too, it’s marvellous for that!

I’m pretty close to buying a SpacePilot on eBay now. :slight_smile:

Can I specifically ask you if your SpacePilot can pan and tilt in 2.79 (which are the two functions the Navigator don’t have anymore)?

Also, is your version a SpacePilot Pro or SpacePilot SP1-USB? (Hoping for the latter as it’s really cheap now :slight_smile: )

Mine is the old original Space Pilot as shown in the pic below. It has the full range of motions in Blender: Forward/back, up/down, left/right and pitch, roll and yaw. 6DOF. It also has a load of buttons which can pretty much be assigned to anything, but by default are: 6 numbered buttons, a button that opens the Blender 6DOF options panel, a button that opens the 3DConnexion software, Esc, Ctrl, Alt and Shift, 4 view keys (top, left, right and front - bottom and back can be got by long pressing their opposite), a ‘fit’ key which works pretty much like hitting numpad period and a few more.

image

Thank you so much! I’m buing one right now! :slight_smile: :slight_smile:

Oops. to get Back and Bottom view I actually hold down Ctrl (on the device or on my actual kb + the front or top view button).

You can even setup your own radial menus. I only have a test one at the moment which has access to the Orientation and Pivot pie menus as well as Ctrl+F and Ctrl+V. Other stuff I’ve added to buttons are things like Numpad 5 to toggle orthographic/perspective and a key to enter walk/fly mode.

Thank you very much again – you’ve saved the day! :slight_smile: I only realized how important that thing is to me when it stopped working.

I found a really nice one on eBay, so I’m really looking forward to this…

1 Like

Hi again :slight_smile:
I got my new old SpacePilot now – but it works exactly like my SpaceNavigator; e.g. it can’t move to the sides or up/down.

So, I wondered if I perhaps could ask which driver you’re using?

I visited 3Dconnexion’s site and looked up SpacePilot under Archived Legacy drivers. But only the SpacePilot Pro is listed, and that driver was actually the one I already had (10.5.13 for Win 10 64 bit).

But perhaps you chose another one, perhaps for another OS?

I’ve also got the original CD or DVD, but as I understand it you actually downloaded your driver so it’d probably be better to get that one, if possible… :slight_smile:

Here’s what I am using

image

It’s from the archived drivers page listed under Space Pilot Pro, and Win 10 64 bit

Thank you so much for your patience, help and super fast reply!

I found the solution – and I’m really, really embarrassed! :cold_face::weary::japanese_goblin::upside_down_face:

I thought I’d tried all setting-combinations known to man, but I had not tried replacing Orbit with Free.

And that did it! (After wasting your time, downloading and trying 5-6 Blender versions, buying another device, un- and re-installing drivers.)

So the settings in the attached image work perfectly for me in Blender versions 2.78-2.79, while ‘Free’ needs to be set to ‘Orbit’ in all other versions (including 2.8):

Also, I LOVE my new, old SpacePilot! :slight_smile: All these fancy functions and views are just absolutely awesome!

1 Like

Excellent. Glad to hear you got it working as desired. The buttons and customisation are handy indeed. I haven’t put much work into setting them up fully, but I was pleased to find I could even set up wee pie menus within their software to use with Blender. You can even have pie menus that invoke further Blender pie menus :stuck_out_tongue:

The main thing I’ve assigned to buttons is numpad 5 to jump in and out of perspective/orthgraphic and a button to enter fly/walk mode. The view keys are fairly useful as is Fit.