3Delight/Blender

zeffii, i had readen the installation.txt included in the archive

"Unpack and move the render_3delight folder into your blender addons folder.You can then enable the addon in the Addons tab of blender user preferencesYou may also need to tell blender the location of your 3Delight installation folder. When you start Blender and the add-on, it will try to guess where your 3Delight folder is, but it may not be correct. You can set this folder explicitly in the Blender Property Editor:
Render Properties -> Search Paths panel -> 3Delight Path
Setting the location in Blender is enough to make it work, however if you want to avoid setting it manually each time, you can force it by editing the 3delight_env.txt file in the render_3delight add-on folder. Simply add the path to the 3Delight installation folder at the end of the first line and save the file. For example:DELIGHT=/Applications/Graphics/3Delight-9.0.84

The location specified in 3delight_env.txt will override anything set in the Render Properties -> 3Delight Path property. Finally, if you have 3Delight’s environment variables set ($DELIGHT, $DL_SHADERS_PATH, etc), these paths will override both the 3Delight Path property and the 3delight_env.txt file.

Matt Ebb, 9 Feb 2011"

I have made the link to 3delight folder in blender, but the error is the same…

I am not sure, but the path for 3delight should be (on windows xp):
C:\Program Files\3Delight\

No ? :slight_smile:

http://img607.imageshack.us/img607/8240/path.jpg

I run Ubuntu 64 bit. The 3delight plugin script works on 2.56-r34678 (gdawg’s last release on graphicall). It seems that the Blender Python api was changed after that version because quite a few other optional scripts broke then. The latest versions by Fish and Nico won’t run it, or any recent character rigs with panel controls for that matter. If anyone needs help to get 3delight to work with Ubuntu and Blender-r34678, just ask.

If it’s not in blender install dir, it’s in C:\Documents and Settings\Administrator\Application Data\Blender Foundation\Blender\2.56, mean the scripts/addons folder !

Yeah, I’m pretty sure almux uses a mac, no?
In which case /might/ be worth looking in the user dirs,
if nothing is found in the blender.app that is.

Tried it in filiciss’ latest build (R34999) under win7-64. When I attempted to enable the Addon my Python console spat out a string of error messages. I was disappointed, but not surprised: Blender is still in some ways a moving target so I will abide in patience. My hat is off to Matt and everyone else who attempts to write addons for Blender under these conditions.

Hi guys, just saw this thread. It’s a bit of a pain about all the errors - a case of bad timing. There have been several changes in Blender’s Python API recently, each of which have broken existing scripts. I released the addon soon after one of these changes, (happened around rev. 34500 or so?), that was fine for about a week, but then there were more API changes in Blender around rev. 34850 which have broken the addon again. I’ve just been away having a week off before entering a busy period for work, so I haven’t had time to investigate what’s needed to update the addon to work again with current SVN builds.

So, until I can find the time to fix it, this addon is only working in a small range of SVN revisions, between about rev. 34500 - 34850.

  • If your error looks like this: unable to get srna from class ‘atmosphereShaders’ then your build of blender is too new
  • If your error looks like this: AttributeError: ‘mathutils.Matrix’ object has no attribute ‘to_translation’ then your build of blender is too old.

If anyone would like to help updating the script, that would be very much appreciated, otherwise you’ll just have to bear with me for a little while until I can fix what’s been broken.

thanks!

Hi guys, just a heads-up, Jeff ‘nfz’ Doyle has updated the code to work in the current bpython API, and I’ve released it as v0.5.2.

Check it out here: http://mke3.net/weblog/3delightblender-0-5-2/

works fine !

thx a lot.

Thanks for the update!

Hi people, I am running blender-2.56a-beta-linux-glibc27-x86_64 and have downloaded 3delight plugin 0.5.2. I am running ubuntu 10 and tried to install the add on. Seems not pick up the addon to enable it. Its driving me a little crazy… anyone?

Does anyone else have problem with file textures? I can’t get blender/3Delight to find them. In the error message it looks like the path gets messed up. 3Delight is awesome.

Thanks delic and Felix_Kütt,

I’ll have a check at this Addons folder anyway soon… :o

Edit: Well folks, i have Addons.exe inside my windows partition… but none within OSX’s one… Maybe only because i only use GraphicAll builds?
I’ll download the Blender.org beta to see if it’s in there.

Edit 2: No addons folder within blender’s official beta… Pugin folder: yes, Addons folder: none.

Hello Sim88, I’ve got the texture thing working… I’m using filiciss’s 32bit build r35453… on Windows XP

Now, under the “…\2.56\scripts\addons\render_3delight” add a folder called “textures” and then place any textures you want to use in there (tiffs work well).

In Blender under 3Delight renderer, select your material, call up a surface shader like “txtplastic” or “simpletexmap” - give the texture a name ( ie: “tex_01” ) and click the little texture icon beside it. Now, instead of browsing to the path, simple enter the name of that texture you want to use ( ie: “mytexturemap.tif” ) and 3delight will automatically look for it in the textures folder you just created.

cheers

Hi, just a little bump - I’ve updated the addon to be compatible with Blender 2.57, plus a couple of new features. Download + info here: http://mke3.net/3delightblender

thanks, do you want this in addons?

I have tried everything in the installation.txt and plus tried manually adding the application path in blender, but still it is not showing any renders. What am I doing wrong. I am in Win7 32 and using the latest version of both the 3delight and the exporter. Kindly guide thank you.

http://img7.imageshack.us/img7/9882/3delight.jpg

Meta-Androcto: I’d prefer not, I’m happy with how it is so far. thanks

nabeelaejaz: Yeah, I just loaded up windows in a virtualbox and it’s not quite working here either. darn, I’ll look into it asap. Thanks for the report

Same problem as nabeelaejaz - just to add to this moan & nag broken :smiley:

Aidan

Hi guys, I uploaded a fix (0.5.4b) for windows issues, please give it a try! http://mke3.net/3delightblender

Interesting stuff! just got it working on ubuntu…

Just got it working… it seems that camera motion blur doesn’t work for rotations, only translations… is that something that needs to be built into shaders?