4suite in Blender, NOT minidom

Hello, everybody…

I’m trying to implement some exporter using XML and XSLT stuff in Blender.
But I got some problem.
How to use XSLT processor in Blender, precisely Python ? I think 4suite package might be a solution(?).
Unfortunately, it did not work under Blender…

As far as I know, in minidom case, it does not support XSLT processor.

So, my question is that there is any way to run XSLT within Python under Blender environment.

Thanks in advance…

I had to do a search to find out what exactly you meant, but Python does have modules to parse XML files, but I guess you already know that.
As for 4suite, what error did your get? It might be a simple case of adding the path to your pythonpath settings.

Thanks for your answer.

Actually, I already set all paths such as python path and site-package path.

Python path is c:\python22\lib;c:\python22\libs
site-package path is c:\python22\lib\site-packages\Ft\Share\Bin

Is there anything else that I have to set ?

My problem is that whenever I run a python script with 4suite, Blender is dead…

My code is as follows:
from Ft.Xml.Xslt.Processor import Processor
from Ft.Xml.Xslt.StylesheetReader import StylesheetReader

processor = Processor()

Is something wrong ?

I want to invoke XSLT processor and run my style sheet from Python.


I can’t really say much about this, I don’t know anything about the program you are trying to use. What exactly do you mean with ‘Blender is dead’, does Blender quit/crash/?? Or do you mean you can’t return to Blender when you start the script? Any error messages?
As for the path, if you can start the script from Blender, I guess the path is ok. For the only external python module I ever used sofar, PIL, I just appended the path to the PYTHONPATH variable itself.

Thanks, again…

It crashed… I got an error message from OS, not Blender.
The message is:
"The memory could not be read…
Click on OK to terminate the application
Click On cancel to debug the application "

I tried to run the Python script on two different machines, NT and win XP.
But, I got the same error message.

BTW, what is the “PIL” ?